Misconfiguration error

31 views
Skip to first unread message

Maria Vitória Rezende Grisi

unread,
Sep 14, 2016, 11:08:12 AM9/14/16
to AtoM Users


Hello,


We've been using AtoM for a while now and we've installed the 2.3 version recently. When we import our csv templates some itens appear misconfigured (like the image bellow). It happens randomly, some itens are correct, some aren't and we don't know why. 

Our operating system is FreeBSD, server Apache 2.4 and server-side PHP 5.6.


Besides that we've noticed that from the csv template 2.2 to the 2.3 the field Digital Object Path has been deleted, since then we haven't been able to import numerous objects at once, so we're doing it manually. Is it possible to upload the images from the computer to AtoM using only the csv 2.3 template?


Thank you.







Dan Gillean

unread,
Sep 14, 2016, 5:03:42 PM9/14/16
to AtoM Users
Hi Maria,

First, though it should be possible to use different configurations, please be aware that we do not test on FreeBSD or with Apache - we use Ubuntu and Nginx in development, testing, and production deployments, and this is what we guarantee will work, and recommend in our documentation. If it turns out that there are issues specific to your installation configuration, we may not be able to offer you support.

I would first try to check your Apache error logs, and see if you can get more information there.

It's strange to see this caused by an import, but the screenshot looks almost like a CSS issue - perhaps you can try recompiling the theme? If it's the base AtoM theme, try:
  • make -C plugins/arDominionThemePlugin

Then clear your cache and restart services (php-fpm, memcached). See if that resolves the issue. If not, please let us know what you find in the error logs.


If items are appearing out of order you might try rebuilding the nested set - this is what manages hierarchical information in AtoM. Try:


The digitalObjectPath column should still work in AtoM 2.3 - if it is not included in the sample CSV template, feel free to add a column. I can still see it in the examples included in AtoM - e.g.:


Sorry for any confusion!


Cheers,

Maria Vitória Rezende Grisi

unread,
Sep 15, 2016, 7:58:10 AM9/15/16
to AtoM Users
Hello,

Thank you for the quick response. I'll see if I can fix it and I'll test the digitalObjectPath column as well.

I'll let you know if I need anything.

Thank you.
Reply all
Reply to author
Forward
0 new messages