Skip to first unread message

Souheir Chemaa

unread,
Jun 22, 2021, 1:30:55 PM6/22/21
to AtoM Users
hello 
I cannot make advanced search in ica atom, the result when i search is always error message. I need help.

Dan Gillean

unread,
Jun 22, 2021, 4:09:47 PM6/22/21
to ICA-AtoM Users
Hi there, 

Any time you encounter a 500 error, the first thing we recommend is to check the webserver logs for more information on the nature of the error.

If you have followed our recommended installation instructions, you can check the most recent error log entries with:
  • sudo tail -f /var/log/nginx/error.log
See:
Feel free to share any related error message you find here if you're not sure how to proceed, and we will try to offer suggestions on next steps. In the meantime, I can offer a few suggestions. In general, they will all involve access to the installation environment and the command line - feel free to forward this to your system administrator or IT person if that is not you. 

Most commands should be run from AtoM's root installation directory - if you have followed our recommended installation instructions, this will typically be /usr/share/nginx/atom.

First, AtoM uses Elasticsearch 5.6 as the library that provides our search index. You can check on the status of your search index with the following command-line task: 
Additionally you can confirm that Elasticsearch is running, as well as restart if needed, with the following commands: 
  • sudo systemctl status elasticsearch
  • sudo systemctl restart elasticsearch
You can try repopulating the search index with the following command: 
Next, there are several tasks in AtoM that can take a long time to execute - longer than the default 1 minute timeout limit that most browsers impose to prevent requests from exhausting all system resources. To avoid the browser timeouts from terminating long-running processes midway through (and potentially causing data corruption), AtoM uses Gearman as a job scheduler to perform these tasks asynchronously in the background. This way, the user can keep using AtoM while the job runs, and the length of the job is not bound to 1 minute or less. 

Examples of things that AtoM currently uses the job scheduler for: 

  • Imports (both CSV and XML) from the user interface

  • Exports from the clipboard

  • Moving a description from one parent to another

  • Generating finding aids and reports

  • Handling DIP uploads from Archivematica

One common source of errors is when the job scheduler needs to be configured, or restarted. The details for installing the job scheduler (Gearman) can be found here: 

If you have already installed and configured Gearman (this should have been done during installation), then it's possible that the job scheduler simply needs a restart. You will know this is the case if you look in the error logs and see a message like, "No Gearman worker available that can handle the job."


To restart the atom-worker, see:

Some notes on this:

  • You can check the status of the atom-worker at any time with: sudo systemctl status atom-worker.This is useful to make sure the restart was successful.

  •  When the worker dies, AtoM will attempt to automatically restart it - however, to prevent the system from being caught in an endless loop, we added a restart limit - 3 retries every 24 hours. You can reset this fail limit with the following command:

  • sudo systemctl reset-failed atom-worker

  • Then run the restart command again if the previous attempts didn't work. 

Finally, there are several tasks that are quick to run, and often resolve common issues in AtoM that can lead to 500 errors. Therse include: 
  • Rebuilding the nested set
  • Generating slugs
  • Restarting PHP-FPM
  • Clearing the application cache
Instructions for all of these, as well as explanations about what the tasks do and why you might run them, can be found on our Troubleshooting page. See: 
I recommend that you try these tasks and restarts if none of the above has worked. 

If this still doesn't resolve the issue, then please share more information about your installation and the nature of the error so we can provide further suggestions. This would include: 
  • The full version number shown in Admin > Settings
  • Whether you've followed our recommended installation instructions or not - and if not, what changes you have made locally
  • Any messages you find in the error logs
  • Any actions that you performed that you believe led to the error (e.g. performing an import, editing a record, etc). 
  • Anything else you think it would be helpful for us to know!
Good luck! Let us know how it goes!

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


On Tue, Jun 22, 2021 at 1:30 PM Souheir Chemaa <chemaa....@gmail.com> wrote:
hello 
I cannot make advanced search in ica atom, the result when i search is always error message. I need help.

--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/adf3cc69-b7c7-47a6-b682-11b36b76ec4an%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages