Help needed...

35 views
Skip to first unread message

Fernando di Perna

unread,
Aug 17, 2022, 11:33:53 AMAug 17
to AtoM Users
Good morning, please, I need confirmation about the feasibility of installing Atom 2.6 on Ubuntu 16.0.4 and what kind of limitations I may encounter in the installation process.
Thank you very much.

Jim Adamson

unread,
Aug 18, 2022, 7:03:22 AMAug 18
to ica-ato...@googlegroups.com
Hi Fernando,

Ubuntu 16.04 went out of support last year, so it's inadvisable using it. I would suggest upgrading it to Ubuntu 18.04 and then installing AtoM 2.6.

Thanks, Jim

On Wed, 17 Aug 2022 at 16:33, Fernando di Perna <fernando...@gmail.com> wrote:
Good morning, please, I need confirmation about the feasibility of installing Atom 2.6 on Ubuntu 16.0.4 and what kind of limitations I may encounter in the installation process.
Thank you very much.

--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/4c2aede6-d103-4ff5-b019-a34ffa4de82cn%40googlegroups.com.


--
Jim Adamson
Systems Administrator/Developer
Facilities Management Systems
IT Services
LFA/023 | Harry Fairhurst building | University of York | Heslington | York | YO10 5DD

Dan Gillean

unread,
Aug 18, 2022, 8:48:22 AMAug 18
to ICA-AtoM Users
Hi Fernando, 

I strongly agree with Jim's advice - we recommend switching to 18.04 and following the official AtoM installation documentation for 2.6 if at all possible. 

If for some reason you have no choice but to use 16.04, I think the biggest issue will be the PHP version. Ubuntu 16.04 includes PHP 7.0 by default, but AtoM 2.6 requires PHP 7.2. This means you will need to manually upgrade the default PHP version to 7.2, and make sure that all the PHP extensions you need to install for AtoM also use the 7.2 version. 

Similarly, you'll need to manually install  MySQL 8, as Ubuntu comes bundled with options for MySQL 5.7 or MariaDB 10.0. AtoM definitely requires v8.0 for the 2.6.4 release. 

There may be other mismatches between the dependencies you need in AtoM and what is included by default in 16.04, so follow the instructions slowly, check the version on anything you install and compare that with what is included by default in 18.04, and then find a way to manually install the correct dependency version whenever there is a mismatch. 

As you can see, things will go much easier if you're able to use 18.04 instead - and you'll be using a more secure, maintained O/S. 

Good luck!

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


On Wed, Aug 17, 2022 at 11:33 AM Fernando di Perna <fernando...@gmail.com> wrote:
Good morning, please, I need confirmation about the feasibility of installing Atom 2.6 on Ubuntu 16.0.4 and what kind of limitations I may encounter in the installation process.
Thank you very much.

--

Fernando di Perna

unread,
Aug 22, 2022, 8:09:43 AMAug 22
to AtoM Users
Thank you so much for yours answers and time...
Bests regards.
Fernando
Reply all
Reply to author
Forward
0 new messages