Error when exporting large fonds as CSV

85 views
Skip to first unread message

JPL Archives

unread,
Nov 6, 2023, 10:49:35 AM11/6/23
to AtoM Users
Howdy all,

When I'm working with large fonds and it comes time to "link physical location" and assign files to series, my workflow has historically been to export the entire fonds as a CSV and carry out these steps there. I've never had trouble.

This time, when I go to export the CSV, I get the following error:
Exception: Unknown record property "authorizedFormOfName" on "QubitStaticPage"

I've seen my fair share of import errors, but never an export one. My situation is not unlike the question asked here, but the answer doesn't quite apply to my situation. 

Any ideas? Appreciate it in advance! 

~kate

Dan Gillean

unread,
Nov 6, 2023, 12:36:12 PM11/6/23
to ica-ato...@googlegroups.com
Hi Kate, 

That is a strange error. Did you upgrade your site recently, by chance? I'm wondering if a step of the upgrade process might have been missed, which could lead to database weirdness.... or if perhaps some other long-running process that terminated unexpectedly might have introduced some data corruption. 

The various maintenance command-line tasks recommended in that thread you linked would in fact be a good idea for you to run, as  - if there is some data corruption present - these can resolve many of the common issues leading to errors of this nature. I would suggest that you try: 
  • Generating slugs
  • Rebuilding the nested set
  • Clearing the application cache
  • Restarting PHP-FPM
  • Repopulating the search index
There are instructions and links to more detailed documentation for all of these tasks on our Troubleshooting documentation page: 
Almost all of these tasks are generally quick and should not in of themselves cause any issues to be run whenever. However, you might want to wait to run the search index rebuild outside of normal business hours. As this runs, records will be unavailable in search and browse pages in your AtoM instance, and depending on the size of your holdings, it can take anywhere from minutes to hours to fully run - so for public-facing production instances, it is generally best run at low traffic times. 

If that doesn't resolve the issue, then I will suggest one more possible avenue for you to explore, and ask some further questions about your site. 

We have a SQL query that you can try running that checks for common forms of data corruption. See: 
Note that any time you use SQL, particularly on a production installation, we strongly recommend you make a backup first! 
There are also some suggestions on how you can fix issues, depending on what you find. 

Alternatively, if you have a backup and would like to try a more automated version of this, one of our developers has turned it into a script that will attempt to apply fixes for you if issues are found. We provide this script AS IS and strongly recommend you make backups and proceed at your own risk  - but we do have at least one positive report back from another user employing this script recently, which is encouraging. 

A link to the copy of the script, a description of what it does, how you can run it locally, as well as the report back from the user who tried it, can all be seen in this forum thread: 
Otherwise, some more information about your installation might help us, such as: 
  • Can you provide me with the full version number shown in Admin > Settings?
  • Does your site include any local customizations or code changes, including a custom theme plugin?
  • How are you exporting this fonds? Pinning it to the clipboard, and then exporting it through the UI using the "include descendants" option? Do other export methods (command-line CSV export; CLI and/or UI export of EAD XML) also produce this error?
  • Have you tried any other fonds? Is it every export, or just this particular archival unit? If just this one, was what you have created via the UI, or via import (or a mix, etc)?
  • Anything else it would be helpful for us to know?
Hopefully with a bit more information, we can provide further suggestions on next steps. In the meantime, let us know how it goes with the suggestions provided here!

Cheers, 

Dan Gillean, MAS, MLIS
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/041793c1-f53e-4243-b3b1-d6eb3bf74549n%40googlegroups.com.

JPL Archives

unread,
Nov 8, 2023, 12:02:52 PM11/8/23
to AtoM Users
Thanks so much for this, Dan. Since it seems like a "rare" sort of error, I've deferred to our digital archivist, who is going to contact Artefactual directly. I'll make sure to return to this thread with whatever potentially useful info we glean from that conversation.

~kate

Reply all
Reply to author
Forward
0 new messages