Report URL error

11 views
Skip to first unread message

ism...@gmail.com

unread,
Aug 10, 2021, 3:40:14 AMAug 10
to AtoM Users

Good morning, I have a problem with the reports associated with the physical storage units. The descriptions of our platform are not linked to physical storage. When you browse AtoM as an anonymous user, and click on the "reports" icon, open the following page http://archivo.dipusevilla.es/index.php/gobierno-2/informationobject/reports where it tells you that it does not exist the report, but gives you the option to "Continue". Then it gives an error that according to the error.log is for trying to access the URL of a report that does not exist, how can I solve this? Greetings.

Dan Gillean

unread,
Aug 10, 2021, 9:38:28 AMAug 10
to ICA-AtoM Users
Hi Isabel, 

Thank you for bringing this to our attention. It seems you have found a bug - I have been able to reproduce this issue locally. Consequently, I have filed a bug ticket here, so that we can track progress on this issue and hopefully include a fix in an upcoming release: 
While physical storage reports can only be generated by authenticated users, by default file and item report generation can be launched by anyone, including public users. However, the problem is that the Continue button displays even if there are no file or item-level descriptions available on the target archival unit. 

I don't have any solid workarounds to suggest at this time. If you are not using the Reports module, then you could potentially make some local code changes to give the Reports link on the description view page a class or unique ID, and then use CSS to hide it entirely. However, CSS will not work for selectively hiding the Continue button on the reports page only when there are no files or items - this would require further PHP code to check the descendant records, meaning that performance in large hierarchies would also need to be considered. 

Hopefully we can address this issue in an upcoming release. In the meantime, apologies for the inconvenience, and thank you again for bringing this issue to our attention!

Regards, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


On Tue, Aug 10, 2021 at 3:40 AM ism...@gmail.com <ism...@gmail.com> wrote:

Good morning, I have a problem with the reports associated with the physical storage units. The descriptions of our platform are not linked to physical storage. When you browse AtoM as an anonymous user, and click on the "reports" icon, open the following page http://archivo.dipusevilla.es/index.php/gobierno-2/informationobject/reports where it tells you that it does not exist the report, but gives you the option to "Continue". Then it gives an error that according to the error.log is for trying to access the URL of a report that does not exist, how can I solve this? Greetings.

--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/96cfed58-7c28-4a8a-905c-421c77f9faa5n%40googlegroups.com.

Portales Municipales

unread,
Aug 11, 2021, 2:09:32 AMAug 11
to AtoM Users
You're welcome, I'm delighted to be able to help and thank you as always for the quick response.
Reply all
Reply to author
Forward
0 new messages