A couple of interesting bugs?

34 views
Skip to first unread message

drba...@ucalgary.ca

unread,
Jan 24, 2022, 2:53:27 PM1/24/22
to AtoM Users
Good afternoon,

We're experiencing some odd behaviour in a couple of places. These are entirely unrelated to each other, I'm sure.

1. When searching for an accession record under "Manage accessions", we are unable to include forward slashes, "/", in the search text. For example, searching for 961/15.1, one of our accessions, yields an Elasticsearch error. However, if we wrap that search in quotation marks, "961/15.1", it works fine.

2. When editing an accession record, if we attempt to add a new Donor (not attach an existing one, but to create a completely new donor using the embedded form), we often get a blank name back in the accession record after clicking submit for the new donor form. If that happens and we then click Save on the accession record, this results in a 500 error. If we instead create the Donor first and then just attach them to the accession, everything is fine.

Any thoughts?

Cheers,

Damian Bauder

Dan Gillean

unread,
Jan 24, 2022, 4:00:48 PM1/24/22
to ICA-AtoM Users
Hi Damian, 

Regarding 1: 

This is a known issue, because slashes are reserved characters in Elasticsearch. You'll find more details and a suggested workaround in the following forum thread:
Regarding 2: 

Can you share with me the error message found in the webserver logs when this happens, and a bit more about your installation? For example: 
  • Full version number as shown in Admin > Settings
  • Any changes you might have made to the default installation instructions
  • Anything else you think will help me to reproduce the issue
I will try to see if I'm able to reproduce this behavior. If so, I'll file a bug ticket so we can hopefully take a look for 2.7, since this is pretty core functionality. If not, hopefully the error log message might help me provide further suggestions. 

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/6e05b906-0cf3-4c33-8941-2d5ad2bd0fa2n%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages