The server returned a 500 Internal Server Error

609 views
Skip to first unread message

moi moi

unread,
Apr 24, 2021, 6:36:42 PM4/24/21
to AtoM Users

Bonjour,
je tentais d'installer atom 2.5.0 avec xampp ( Apache/2.4.37 (Win32) OpenSSL/1.1.1a PHP/7.3.0 , mysqlnd 5.0.12 )
au moment de l'installation il me demande search index (atom, port 9200
quand je clique sur suivant j'ai eu ce message :
"The server returned a 500 Internal Server Error"

cmt le regler
merci d'avance
nadia


Dan Gillean

unread,
Apr 26, 2021, 9:56:44 AM4/26/21
to ICA-AtoM Users
Salut Nadia, 

Before offering some troubleshooting suggestions, I would like to provide a few general reminders: 

First, please note that we do not test or support Xampp installations - hopefully other community users can offer you guidance, but it can be difficult to match the dependency requirements in Xampp. 

In your case, I recommend that you take a look at the technical requirements and installation documentation for AtoM 2.5.0 if that's what you'd like to install. You will find that: 
  • PHP 7.2 is the latest PHP version supported in 2.5 (and 2.6 currently). We will be upgrading this for 2.7, and there are already some fixes in 2.6.x that will help with compatibility, but in version 2.5, I would expect you to see errors, warnings, and notices when trying to use PHP 7.3. 
  • AtoM 2.5 expects MySQL server v5.7. If you are running 5.0, there will almost certainly be problems! 
  • It's worth checking what version of Elasticsearch you have installed as well. AtoM 2.5 supports up to version 5.6 - later versions (such as 6.x and 7.x) or versions earlier than 5 are very likely to cause issues!
If you need to install AtoM on a Windows server, we strongly recommend a full Ubuntu 18.04 virtual machine, rather than a preconfigured environment like Xampp. That way you can follow the official installation documentation once you've created the base Ubuntu virtual appliance. Alternatively, if this is for testing or development on a personal computer such as a laptop, we already provide cross-platform environments, such as our Vagrant box: 
Keep in mind that AtoM is intended to be installed on a server for use in a production environment. The Vagrant box is NOT intended to be used in production as your primary public-facing AtoM site!

If you do intend to keep using Xampp, then you may need to downgrade some things (such as the PHP version) and upgrade others (such as the MySQL server version). 

Finally, keep in mind that version 2.5 is fairly old at this point - almost 2 years old! We have made a number of performance improvements in 2.6.x, and there have been 2 security releases that patch issues that also affect version 2.5! Please see our release notes for more information: 
If you really cannot install 2.6 instead, there are patches provided for 2.5  - we strongly recommend you apply them. See the release announcements for v2.6.2 and 2.6.4 for more information and a link to the patches: 
Now, a few troubleshooting tips: 

Typically, whenever you encounter a 500 error, we first recommend that you take a look at the webserver error logs for more information. In Nginx these can be accessed at /var/log/nginx/error.log. You can try the following for Apache, to see if it works - if not, you will need to consult the Apache documentation: 
One of the most common reasons we see 500 errors relating to Elasticsearch is because there is not enough memory available. Elasticsearch is very memory-intensive during installation and configuration. On our Technical requirements page we recommend the following for production-ready AtoM installations: 
  • Processor: 2 vCPUs @ 2.3GHz
  • Memory: 7GB
  • Disk space (processing): 50GB at a minimum for AtoM’s core stack plus more storage would be required for supporting any substantial number of digital objects.

If at all possible I would suggest increasing the available RAM in your installation environment. Once installed and configured, this could possibly be reduced some (4GB of RAM seems to work okay for most medium-sized installations), but it will help the installation process a lot if you have more RAM during the configuration stage. 

So, check your dependencies and upgrade or downgrade as needed; check the available RAM and increase it if possible; and if none of that helps, check the Apache error logs and share what you find there - hopefully we will be able to offer further suggestions. 

Let us know how it goes!

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/02124aed-4ee0-455b-947b-7c22082f090fn%40googlegroups.com.

MOUSSAOUI Ouahiba

unread,
Apr 27, 2021, 8:02:40 AM4/27/21
to ica-ato...@googlegroups.com
Hi DAN
merci beaucoup pour toutes ces explications très pointues
je vais voir avec notre informaticien et vous tenir au courant
merci beaucoup
très cordialement
nadia

You received this message because you are subscribed to a topic in the Google Groups "AtoM Users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/ica-atom-users/Yo2wOZyjDUY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/CAC1FhZ%2BWUte1K56Nqfephj4pFcJh%3DdNTbCfnK_dvBGXeuq_NKA%40mail.gmail.com.

MOUSSAOUI Ouahiba

unread,
Apr 29, 2021, 7:11:12 AM4/29/21
to ica-ato...@googlegroups.com
Hi DAN ,
je reviens encore une fois vers vous
j'ai installé atom 2.6.2 avec xampp 7.3 ( Apache/2.4.37 (Win32) OpenSSL/1.1.1a PHP/7.3.0 , mysqlnd 5.0.12 )
sauf qu'au moment de l'installation (configure database) j'ai eu ce message

Unable to open PDO connection [wrapped: SQLSTATE[HY000] [1044] Access denied for user ''@'localhost' to database 'qubit']

est ce dû à la version php 7.3, vu les prerequis des versions ATOM 2.6.2. ça demande php 7.2

xampp est utilisé dans notre boîte pour d'autres applications donc je ne peux installer wampserver
merci d'avance
nadia

Le lun. 26 avr. 2021 à 14:56, Dan Gillean <d...@artefactual.com> a écrit :
You received this message because you are subscribed to a topic in the Google Groups "AtoM Users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/ica-atom-users/Yo2wOZyjDUY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/CAC1FhZ%2BWUte1K56Nqfephj4pFcJh%3DdNTbCfnK_dvBGXeuq_NKA%40mail.gmail.com.

Dan Gillean

unread,
Apr 29, 2021, 10:09:22 AM4/29/21
to ICA-AtoM Users
Salut Nadia, 

First, yes - as I noted in my first post, I suspect you will get errors if you try to proceed with PHP 7.3, rather than 7.2. I also recommend you check your MySQL version - AtoM 2.6.2 requires MySQL 8.0, and you will definitely encounter problems immediately if you are trying to use an earlier version, because we have used some of the new query methods available in v8.0 to improve performance in the latest AtoM versions. I recommend you address these before any other troubleshooting. 

As for this specific error message, it may be indicating another configuration problem. 

Looking at the error, it seems to me that AtoM thinks your MySQL database has a user named localhost and the database is named qubit. This may be because the credentials were entered incorrectly when running the web installer. I would start by checking what credentials were actually used, and if necessary, correcting these in AtoM's web installer. 

I don't know how well the instructions will translate in a Xampp environment since your files may be in different places, but we describe 2 ways of checking the MySQL credentials in the following link: 
The first is to look in AtoM's config/config.php file. The second method is to check MySQL's /root/.my.cnf file. Either of these locations should tell you the database user and database name that AtoM is expecting. 

You can restart AtoM's web installer by returning to [Base URL of site]/index.php/sfInstallPlugin/configureDatabase. For example, during initial configuration, if youdon't yet have a DNS record in place, this might be: 
Make sure the credentials are entered properly there. Then try restarting services such as PHP-FPM. You can also clear AtoM's cache with the following, run from AtoM's root installation directory: 
  • php symfony cc
Good luck!

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


Reply all
Reply to author
Forward
0 new messages