Command tools:purge doesn't work

28 views
Skip to first unread message

Franck Dupont

unread,
Oct 9, 2015, 7:47:42 AM10/9/15
to ICA-AtoM Users
Hello,

I just installed ATOM on a Debian Wheezy server.

The application (site, backoffice) and command line options ("php symfony) are ready.

But the command :
php symfony tols:purge


Returns :
At least one of the following command line options is missing: title, description, url, email, username and/or password.  

And doesn't prompt me informations as usual.

An idea ?

Thx.

Franck.




Sarah Romkey

unread,
Oct 9, 2015, 11:24:50 AM10/9/15
to ica-ato...@googlegroups.com
Hello Franck,

It may have just been a typo in your forum post, and not in what you actually ran, but I assume you meant:

php symfony tools:purge

?

Cheers,

Sarah

Sarah Romkey, MAS,MLIS
Systems Archivist
Artefactual Systems
604-527-2056
@archivematica / @accesstomemory



--
You received this message because you are subscribed to the Google Groups "ICA-AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To post to this group, send email to ica-ato...@googlegroups.com.
Visit this group at http://groups.google.com/group/ica-atom-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/212d94c1-80c3-49f2-95f8-9a036965a658%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Jesús García Crespo

unread,
Oct 9, 2015, 11:55:04 AM10/9/15
to ica-ato...@googlegroups.com
Hi Franck,

In addition to what Sarah just said,

`tools:purge` will not prompt the user for the necessary parameter if the php5-readline extension has not been installed. In Debian, run `sudo apt-get install php5-readline` and the task should work as you expect. Alternatively, you can pass the parameters as command line flags, e.g. `php symfony tools:purge --title <title> --description <description> --username <username> [...]`



On Fri, Oct 9, 2015 at 4:47 AM, Franck Dupont <kyf...@gmail.com> wrote:

--
You received this message because you are subscribed to the Google Groups "ICA-AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To post to this group, send email to ica-ato...@googlegroups.com.
Visit this group at http://groups.google.com/group/ica-atom-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/212d94c1-80c3-49f2-95f8-9a036965a658%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Jesús García Crespo,
Software Engineer, Artefactual Systems Inc.
http://www.artefactual.com | +1.604.527.2056

Franck Dupont

unread,
Oct 11, 2015, 9:07:39 PM10/11/15
to ICA-AtoM Users
That's the ticket Jesús !

php5-readline isn't installed in Debian Wheezy by default.

@Sarah : yes, it's a typo, sorry ;-)

Thanks.

Franck.
Reply all
Reply to author
Forward
0 new messages