Problem with DIP Upload

71 views
Skip to first unread message

Tatiana Canelhas

unread,
Sep 6, 2019, 11:04:20 AM9/6/19
to AtoM Users
Hi guys, 

I was trying to upload a DIP from archivematica to AtoM. 
In Archivematica, everything worked perfectly, no errors there.

But, as I open the description in AtoM, the object I sent is not there.

I looked into /tmp directory into AtoM server, and the DIP is there, with the object inside /objects directory, as It should be.

I am using AtoM 2.4, Archivematica  1.7.2 and Ubuntu 16.04.

What can I do?

Thanks,
Tatiana Canelhas

Dan Gillean

unread,
Sep 6, 2019, 3:14:56 PM9/6/19
to ICA-AtoM Users
Hi Tatiana, 

I would start by making sure that the job scheduler is properly installed and running, and that the qtSwordPlugin is enabled in Admin > Plugins. If the plugin not enabled previously, then you will need to restart the atom-worker. 

I would also suggest that you check your webserver error logs and see if there are any issues noted?

Let us know what you find! 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/66c6c36c-fbb9-462e-a95e-7bb9e870cb12%40googlegroups.com.

Tatiana Canelhas

unread,
Sep 6, 2019, 3:34:29 PM9/6/19
to AtoM Users
Hi Dan,

this is what i found:

[info] [2019-09-06 08:28:35] Job 140797 "qtSwordPluginWorker": Job started.
[info] [2019-09-06 08:28:35] Job 140797 "qtSwordPluginWorker": A package was deposited by reference.
[info] [2019-09-06 08:28:35] Job 140797 "qtSwordPluginWorker": Location: file:///teste4-acf095e8-5bde-4ef7-85b7-d3ae28c6fad4
[info] [2019-09-06 08:28:35] Job 140797 "qtSwordPluginWorker": Processing...
[info] [2019-09-06 08:28:35] Job 140797 "qtSwordPluginWorker": Object slug: teste
[info] [2019-09-06 08:28:35] Job 140797 "qtSwordPluginWorker": Exception: Level of description not found: Directory

    If I add a new level of description called Directory, will it work?

    Thanks,
    Tati

    Tatiana Canelhas

    unread,
    Sep 6, 2019, 3:43:08 PM9/6/19
    to AtoM Users
    Dan,

    now that I created the Directory level of description, the job log is:

    [info] [2019-09-06 12:36:43] Job 140870 "qtSwordPluginWorker": Job started.
    [info] [2019-09-06 12:36:43] Job 140870 "qtSwordPluginWorker": A package was deposited by reference.
    [info] [2019-09-06 12:36:43] Job 140870 "qtSwordPluginWorker": Location: file:///teste6-87277ee0-eaa3-4143-b484-5835d39aa8af
    [info] [2019-09-06 12:36:43] Job 140870 "qtSwordPluginWorker": Processing...
    [info] [2019-09-06 12:36:43] Job 140870 "qtSwordPluginWorker": Object slug: teste
    [info] [2019-09-06 12:36:47] Job 140870 "qtSwordPluginWorker": Job finished.

    BUT, it created all directories from the package, with no object on it.

    Take a look at the image attached.

    Thanks,
    Tati
    Capture.PNG

    Dan Gillean

    unread,
    Sep 6, 2019, 5:00:36 PM9/6/19
    to ICA-AtoM Users
    Wow, interesting. I've not seen that before. It may be because the job was only partially completed, and it picked up partway through and didn't treat it as a DIP? I'm not sure. 

    Overall, I think you might want to try posting to the Archivematica forum - it sounds like this could possibly be a workflow issue. For example, if it's looking for levels of description, then perhaps you were using the SIP arrange from backlog feature? If so, the level needs to be created in AtoM first, and then the option to update the AtoM levels in Archivematica's Administration tab needs to be applied. You then choose the level of description for each directory in the SIP arrange panel before you generate your DIP and send it to AtoM. 

    I would suggest deleting this and trying the test again from scratch as a first step, to see if it helps - after completing the steps above if you are using SIP arrange!

    Dan Gillean, MAS, MLIS
    AtoM Program Manager
    Artefactual Systems, Inc.
    604-527-2056
    @accesstomemory

    --
    You received this message because you are subscribed to the Google Groups "AtoM Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.

    Tatiana Canelhas

    unread,
    Sep 6, 2019, 7:12:09 PM9/6/19
    to AtoM Users
    Dan,

    I was not using backlog. I was creating the SIP directly, without sending the transfer to backlog.

    Tati
    To unsubscribe from this group and stop receiving emails from it, send an email to ica-ato...@googlegroups.com.

    Dan Gillean

    unread,
    Sep 10, 2019, 10:59:37 AM9/10/19
    to ICA-AtoM Users
    Hi Tatiana, 

    That is very strange. I would still suggest that you delete the last effort, clear the temp directory, and try the transfer again. It sounds to me like the process was interrupted, and when it picked up again it was not following the usual DIP upload workflow. I'm hoping this is just a strange blip - but let us know how it goes! 

    I will also add that the AtoM 2.5.2 release includes a number of DIP upload fixes, so that it can work with the Archivematica 1.10 release - so upgrading your instances is another option. 

    Cheers, 

    Dan Gillean, MAS, MLIS
    AtoM Program Manager
    Artefactual Systems, Inc.
    604-527-2056
    @accesstomemory

    To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/52f721ab-e098-46e0-8008-2f982fe9c642%40googlegroups.com.

    Tatiana Canelhas

    unread,
    Sep 11, 2019, 12:00:57 PM9/11/19
    to AtoM Users
    Dan, I found this bug https://projects.artefactual.com/issues/11213

    Do you think it can be related?

    Dan Gillean

    unread,
    Sep 11, 2019, 12:40:27 PM9/11/19
    to ICA-AtoM Users
    Hi Tatiana, 

    Probably not. I noticed this ticket was still marked as being in review, but I followed the pull request and checked in with the Archivematica team, and it seems this was merged into the 1.7.0 Archivematica release - so you should have the fix for this bug in your AM instance anyway. 

    If possible, I would strongly recommend you upgrade to Archivematica 1.10 and AtoM 2.5.2 - I suspect there might be a lot of other bug fixes in both applications that would benefit you! In the meantime, I still suggest deleting the import and trying the transfer again - and continue to follow up on the Archivematica list-serv to see if they have further suggestions for you. 

    Cheers, 

    Dan Gillean, MAS, MLIS
    AtoM Program Manager
    Artefactual Systems, Inc.
    604-527-2056
    @accesstomemory

    To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/272cba3d-8902-412a-82b4-579ef882a7a4%40googlegroups.com.

    Tatiana Canelhas

    unread,
    Sep 11, 2019, 1:27:47 PM9/11/19
    to ica-ato...@googlegroups.com
    Yeah, i already tried that. Deleted and tried again. But got the Same error.

    :(

    You received this message because you are subscribed to a topic in the Google Groups "AtoM Users" group.
    To unsubscribe from this topic, visit https://groups.google.com/d/topic/ica-atom-users/PJBjVn-r1VM/unsubscribe.
    To unsubscribe from this group and all its topics, send an email to ica-atom-user...@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/CAC1FhZLbAYFCMTD7-qKqE3ZmtUqBy2cEzQQ6e56Wq0uh9U%2BfLQ%40mail.gmail.com.

    Tatiana Canelhas

    unread,
    Sep 11, 2019, 1:29:28 PM9/11/19
    to ica-ato...@googlegroups.com
    I thought of this bug because of the directory level of description error... because it happened to me, and just stopped because I added the directory level.

    Em qua, 11 de set de 2019 13:40, Dan Gillean <d...@artefactual.com> escreveu:
    You received this message because you are subscribed to a topic in the Google Groups "AtoM Users" group.
    To unsubscribe from this topic, visit https://groups.google.com/d/topic/ica-atom-users/PJBjVn-r1VM/unsubscribe.
    To unsubscribe from this group and all its topics, send an email to ica-atom-user...@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/CAC1FhZLbAYFCMTD7-qKqE3ZmtUqBy2cEzQQ6e56Wq0uh9U%2BfLQ%40mail.gmail.com.
    Reply all
    Reply to author
    Forward
    0 new messages