Copyright statement not opening

38 views
Skip to first unread message

CLK-Archi...@winnipeg.ca

unread,
Mar 20, 2020, 2:59:04 PM3/20/20
to AtoM Users
Hi all,

I'm quite new to using PREMIS rights on AtoM (2.5.3), but I've run into an issue I can't seem to troubleshoot. I'm trying to get a copyright statement pop-up working for when users click on masters, but for a reason I can't figure out, there is no pop-up, it just proceeds directly to the master digital object as if nothing was enabled at all.

I have done the following:
  • Enabled copyright statement in settings->permissions;
  • Written "test" in the copyright statement text box (preview works fine);
  • Checked off all boxes (master, reference, thumbnail) in the copyright row for the display PREMIS act;
  • Added a rights statement to a (published) description that is act->display and restriction->conditional, with dates from 2020-03-18 to 2020-05-07;
  • Double checked that non-logged in users can view masters;
  • Tried it without the copyright-conditional boxes checked off for display action;
  • Disabled pop-up blockers on my browser, just in case.
I believe the above is everything I'm supposed to do to get this work, but there's just nothing. Does anyone know what the problem could be or if I'm missing something?

Thanks,
Jarad

Dan Gillean

unread,
Mar 20, 2020, 4:01:37 PM3/20/20
to ICA-AtoM Users
Hi Jarad, 

From the sounds of it, you've already looked over the documentation, but for reference, see: 
I've run a quick test in our qa/2.6.x development branch, and confirmed that the copyright pop-up is working there. I don't know of any regression fixes we've added in 2.6, so I assume for now this means it is also working in 2.5.x

A few quick checks: 
  • You've applied the act: Display. Have you confirmed that this is also the actionable PREMIS act set in Admin > Settings > Permissions? The default Act used when first installing AtoM is "Disseminate." If your actionable Act in the settings is not Display, then either you will need to change it in the settings (which could impact previous actionable rights statements you've added), or else change the Rights statement you've added on the record where you're trying to enable the pop-up
  • Is your digital object locally uploaded, or linked via an external URL? If the latter, unfortunately the pop-up statement does not currently work with external digital objects
  • Have you tried clearing your browser cache?  
Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/ade3dd8b-3eec-4bc4-8604-784c3382513a%40googlegroups.com.

CLK-Archi...@winnipeg.ca

unread,
Mar 23, 2020, 9:33:38 AM3/23/20
to AtoM Users
Hi Dan,

Thanks for the reply.

  • Yes, Act: display is both set in the permissions setting as well as the description in question. See screenshots below, in case I'm misunderstanding.
  • I'm assuming that uploading objects via CSV digitalObjectPath field counts as local upload (the images are on the server)?
  • Tried clearing cash and accessing from incognito window

Capture.PNG

Capture2.PNG

To unsubscribe from this group and stop receiving emails from it, send an email to ica-ato...@googlegroups.com.

Dan Gillean

unread,
Mar 24, 2020, 11:01:57 AM3/24/20
to ICA-AtoM Users
Hi Jarad, 

Feeling a bit stumped on this one, since I can't reproduce and everything you're telling me suggests you are correctly following the instructions. I've asked a developer to try reproducing as well, and will get back to you once we've followed up internally. 

If we still can figure out what's happening, I know you use Artefactual's services, so we will follow up with you via our support channel, so we can look at your particular instance and see if there's something specific we can identify that is causing this - and to see if we can reproduce it elsewhere in your environment. 

More soon,

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him

To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/ebd050dd-43bd-4f53-985d-437d8cdb216c%40googlegroups.com.

CLK-Archi...@winnipeg.ca

unread,
Mar 24, 2020, 11:06:12 AM3/24/20
to AtoM Users
Thanks, Dan. Appreciate it.

Cheers,

Dan Gillean

unread,
Mar 24, 2020, 3:53:48 PM3/24/20
to ICA-AtoM Users
Hi again Jarad, 

Our developer was also unable to reproduce... unless he messed with the Nginx configuration settings. Specifically, if this block was missing: 

location ~* ^/uploads/r/(.*)$ {
   include /etc/nginx/fastcgi_params;
   set $index /index.php;
   fastcgi_param SCRIPT_FILENAME $document_root$index;
   fastcgi_param SCRIPT_NAME $index;
   fastcgi_pass atom;
}


Then he was able to reproduce. 

I'm sharing this in case it helps anyone else in the future coming across this thread. In the meantime, I've filed an internal ticket in our support system so we can investigate your hosted site, and we'll be following up with you via our usual client channels once someone has investigated further. 

If, in the course of this, we learn anything else helpful to other users, I'll update this thread accordingly.

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him

To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/2ac605ae-58fc-4ae0-93e1-fc532a00274e%40googlegroups.com.

CLK-Archi...@winnipeg.ca

unread,
Mar 26, 2020, 2:37:24 PM3/26/20
to AtoM Users
Thanks for looking into this, Dan.

Cheers,
Jarad
Reply all
Reply to author
Forward
0 new messages