huge number of nginx error_log entries: 404 error page by the action "search/autocomplete"

26 views
Skip to first unread message

Ricardo Pinho

unread,
Jan 27, 2021, 6:54:16 AM1/27/21
to ica-ato...@googlegroups.com
Dear all,

We have detected a huge number of error reports in the nginx error_log files, like the examples below, of the type: "search/autocomplete"
Sometimes they appear isolated in time, but also occur almost simultaneously during the user typing the text, like the examples below:

2021/01/22 16:50:30 "GET /index.php/search/autocomplete?query=VINC0000&repos= HTTP/1.1"
2021/01/22 16:50:30 "GET /index.php/search/autocomplete?query=VINC00000&repos= HTTP/1.1
2021/01/22 16:50:32 "GET /index.php/search/autocomplete?query=VINC00000&repos= HTTP/1.1"

We are using AtoM 2.5.2 on Ubuntu 18.04 LTS, installed accordingly to the official accesstomemory manual install procedure.

I've searched for something related and found this:
"Race condition in autocomplete.js"
For greater context: it turns out this is a result of the recently-filed but age-old minor bug, #7198.
If the user enters data too fast before the slow autocomplete.js finishes, it will throw an error. Had nothing to do with this issue, or with the ES 1.3 upgrade. Sorry for the confusion!

Could this be the problem? Can this be corrected to avoid throwing daily a huge number of errors into the log?

Thank you in advance.
Best regards,
--
Ricardo Pinho

PS.
Complete error lines from nginx "error.log":

2021/01/22 16:50:30 [error] 1435#1435: *105344 FastCGI sent in stderr: "PHP message: This request has been forwarded to a 404 error page by the action "search/autocomplete"" while reading response header from upstream, client: 188.37.21.36, server: _, request: "GET /index.php/search/autocomplete?query=VINC0000&repos= HTTP/1.1", upstream: "fastcgi://unix:/run/php7.2-fpm.atom.sock:", host: "www.vinculum-database.fcsh.unl.pt", referrer: "https://www.vinculum-database.fcsh.unl.pt/index.php/informationobject/browse?topLod=0&query=VINC003333&repos="

2021/01/22 16:50:30 [error] 1435#1435: *105344 FastCGI sent in stderr: "PHP message: This request has been forwarded to a 404 error page by the action "search/autocomplete"" while reading response header from upstream, client: 188.37.21.36, server: _, request: "GET /index.php/search/autocomplete?query=VINC00000&repos= HTTP/1.1", upstream: "fastcgi://unix:/run/php7.2-fpm.atom.sock:", host: "www.vinculum-database.fcsh.unl.pt", referrer: "https://www.vinculum-database.fcsh.unl.pt/index.php/informationobject/browse?topLod=0&query=VINC003333&repos="

2021/01/22 16:50:32 [error] 1435#1435: *105344 FastCGI sent in stderr: "PHP message: This request has been forwarded to a 404 error page by the action "search/autocomplete"" while reading response header from upstream, client: 188.37.21.36, server: _, request: "GET /index.php/search/autocomplete?query=VINC000001&repos= HTTP/1.1", upstream: "fastcgi://unix:/run/php7.2-fpm.atom.sock:", host: "www.vinculum-database.fcsh.unl.pt", referrer: "https://www.vinculum-database.fcsh.unl.pt/index.php/informationobject/browse?topLod=0&query=VINC003333&repos="

José Raddaoui

unread,
Jan 27, 2021, 3:16:06 PM1/27/21
to AtoM Users
Thanks for bringing this up, Ricardo,

While this is not an actual problem, we agree that a no results query shouldn't return a 404 response code. We have created the following ticket to keep track of the issue:


Best regards,
Radda.

Ricardo Pinho

unread,
Jan 27, 2021, 5:08:11 PM1/27/21
to ica-ato...@googlegroups.com
Thank you José for the fast reply.
And for creating a ticket to solve the issue.
Cheers,
Ricardo

--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/30cc732b-dfd4-40dd-845d-777c27c953d0n%40googlegroups.com.


--
Ricardo Pinho
Reply all
Reply to author
Forward
0 new messages