Problem with reference/thumbnail auto-generation for pdf files

175 views
Skip to first unread message

Jonathan Chu

unread,
Dec 18, 2018, 4:08:46 AM12/18/18
to AtoM Users
Hi everyone,

We are running AtoM 2.4 on Ubuntu for St. John's College of the University of Hong Kong.

We have been using AtoM for almost 1 year and the reference/thumbnail auto-generation function has been working fine for both photos and pdfs. However, when we tried to upload a pdf file yesterday, both the reference and thumbnail were not generated. The result is as shown in the following screenshots:

For the carousel:

Screenshot 2018-12-18 at 4.53.47 PM.png


For the relevant archival description page:


Screenshot 2018-12-18 at 4.53.58 PM.png


For the digital object edit page:


Screenshot 2018-12-18 at 4.54.32 PM.png


This is a new problem for us. It does not affecting image (jpeg) files. At first, it also did not affect pdf digital objects uploaded earlier. The master file is still there, and can be accessed by clicking the "file" icon. We have also tried the "Or auto-generate a new representation from master image" function on the edit page, but does not work.

We found a similar topic in this group: https://groups.google.com/forum/#!searchin/ica-atom-users/auto$20generate%7Csort:date/ica-atom-users/lQ0wt2SnWqY/lzxkYivU-ncJ. Our administrator followed the command for regenerating digital derivatives mentioned there (i.e. php symfony digitalobject:regen-derivatives). The data log after running this command is as follows:

identify: not authorized `/usr/share/nginx/atom/uploads/r/archives-of-st-johns-college-hku/e/b/1/ebla905bablc7b33bca9bbbb079e58a817df731e91687f732359e6ac5a/SJH-03_w.pdf' @ error/constitute.c/ReadImage/412.

Following this, all other pdf digital objects are plagued. Both references and thumbnails have disappeared.

Has this been encountered by anyone? Is there a solution?

Thanks!

Jonathan Chu

Dan Gillean

unread,
Dec 18, 2018, 10:16:08 AM12/18/18
to ICA-AtoM Users
Hi Jonathan, 

I think that you might be running into the following issue, caused by a change in ImageMagick. Please see this thread for more information and a solution: 
Once you have this fix in place, you can try the derivatives regeneration task again to see if it resolves the issue. 

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To post to this group, send email to ica-ato...@googlegroups.com.
Visit this group at https://groups.google.com/group/ica-atom-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/b4a3d75f-361b-43e4-8356-3a5c50dfb035%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Jonathan Chu

unread,
Dec 19, 2018, 8:00:25 AM12/19/18
to AtoM Users
Hi Dan,

Thank you very much! We overlooked this thread. We have followed the solution and it is now sorted.

Cheers,
Jonathan
Reply all
Reply to author
Forward
0 new messages