Update with CSV unable to match row

50 views
Skip to first unread message

Marc Casals

unread,
Nov 29, 2022, 4:36:22 PM11/29/22
to AtoM Users
Hello,
I'm new to AtoM  + Archivematica and I'm trying to do a bulk update of simple items but it seems I have no way to update as the Import task can't identify the Archival Descriptions I'm modifying. I even tried exporting the csv from the clipboard and then importing without modifying the csv but it just skips all the rows. It's a bit frustrating because in this case I have +300 images and I can't update them one by one.

Here's the console output.
[info] [2022-11-29 13:22:16] Job 9068 "arFileImportJob": Importing CSV file: isad_0000000001.csv.
[info] [2022-11-29 13:22:16] Job 9068 "arFileImportJob": Skipping unmatched records.
[info] [2022-11-29 13:22:16] Job 9068 "arFileImportJob": Skipping matched records.
[info] [2022-11-29 13:22:16] Job 9068 "arFileImportJob": Update type: match-and-update
[info] [2022-11-29 13:22:17] Job 9068 "arFileImportJob": php '/usr/share/nginx/atom/symfony' 'csv:import' --update="match-and-update" --skip-unmatched --quiet --user-id="443" --source-name='isad_0000000001.csv' '/usr/share/nginx/atom/uploads/tmp/TMP1889e8b3.csv'
[info] [2022-11-29 13:22:17] Job 9068 "arFileImportJob": Row 1: Unable to match row. Skipping record: (id: 02.053.051.001.0001)
[info] [2022-11-29 13:22:17] Job 9068 "arFileImportJob": Row 2: Unable to match row. Skipping record: A-1_1693-1725_0001.jpg (id: )
[info] [2022-11-29 13:22:17] Job 9068 "arFileImportJob": Row 3: Unable to match row. Skipping record: A-1_1693-1725_0002.jpg (id: )
[info] [2022-11-29 13:22:17] Job 9068 "arFileImportJob": Row 4: Unable to match row. Skipping record: A-1_1693-1725_0003.jpg (id: )
[info] [2022-11-29 13:22:17] Job 9068 "arFileImportJob": Row 5: Unable to match row. Skipping record: A-1_1693-1725_0004.jpg (id: )
[info] [2022-11-29 13:22:17] Job 9068 "arFileImportJob": Row 6: Unable to match row. Skipping record: A-1_1693-1725_0005.jpg (id: )
....


As you can see the images don't have identifier but it can't be the problem because other archival descriptions have and it can't identify them either.

Thanks in advance

Dan Gillean

unread,
Nov 30, 2022, 8:29:12 AM11/30/22
to ica-ato...@googlegroups.com
Hi Marc, 

Have you taken a look at the documentation for the matching logic? We have tried to update it to make it as clear as possible, but... long story short, the original matching logic was not very intuitive, and mostly designed for system to system updates, not roundtripping in a single system. 

Please see: 
For more detail on how matching works, why it doesn't work great roundtripping in a single system, and some suggestions for working around these limitations, see: 
Basically, my suggestion would be to export your target descriptions, make changes in the resulting CSV file, and then import it from the command-line using the --roundtrip option, as this will bypass many of the other matching options that your CSV is not currently matching on. See: 
Regards, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/f02ab0a7-b17b-4e5e-b637-9b8b1cb7216bn%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages