Problems installing 1.0.9

41 views
Skip to first unread message

Helen

unread,
Jun 11, 2010, 6:03:59 AM6/11/10
to ICA-AtoM Users
Hi there - We've been looking at ICA-AtoM for our archive collection
at <a href="http://www.womenslibrary.org.uk/">Glasgow Women's Library</
a>, and although it looks very promising, we've had problems
installing the current version on our web server, and need a little
help in tracking down the problem.

The installation process gets stuck at the 'Loading data' stage - it
seems to be using up more PHP memory than the minimum recommended in
the ICA-AtoM documentation.

We get the error message:

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to
allocate 24 bytes) in [ICA-AtoM root]/lib/model/om/BaseObject.php on
line 422

(It doesn't always get stuck at the same place - that's just the file
name that comes up most often)

We're on a shared server, so we have no root access and limited
control over what settings we can change - increasing the PHP memory
limit being one of the things our hosting provider controls. Because
we had previously requested the PHP memory limit be raised to the
recommended 64MB, I want to be absolutely certain that this is the
cause of our installation problems before I go back to them -
basically that the PHP memory limit is the cause of the problem, and
not a side effect of a different problem with the installation
process.

Alternatively, I'd be grateful to know if there's a way to get round
this problem. (Skipping ahead to the final 'Configure site' stage
didn't work, surprisingly ;)

We installed the 1.0.9 version on our local server without any
problems with the PHP memory limit set to 64MB, but it's XAMPP rather
than a Linux server - I'm not sure how much difference that would
make, as the 1.0.9 version doesn't seem to need the <a href="http://
qubit-toolkit.org/wiki/index.php?title=Xampp_installation">convoluted
setup process</a> required by earlier versions when installing on
XAMPP.

Thanks in advance for any help!

Evelyn McLellan

unread,
Jun 11, 2010, 3:59:34 PM6/11/10
to ICA-AtoM Users
Hi Helen,

Thanks very much for your detailed error report. I have passed this on
to our developers and one of them will get back to you soon.

Evelyn McLellan
ICA-AtoM Community Manager

David Juhasz

unread,
Jun 11, 2010, 5:49:53 PM6/11/10
to ica-ato...@googlegroups.com
Hi Helen,

Yes, you are definitely running into the PHP memory limit, though I
must admit that I'm surprised that 64MB isn't enough memory for the
data load stage. :-/ Asking your hosting provider for a 128MB
memory_limit is really the only way to proceed at this point
unfortunately.


Regards,

David Juhasz,
Software Engineer, Artefactual Systems Inc.
http://www.artefactual.com | P: 604.527.2056 | F: 604.521.2059

Helen

unread,
Jul 2, 2010, 9:17:44 AM7/2/10
to ICA-AtoM Users
Hi Evelyn & David - thanks for your quick response, and apologies for
not responding sooner. I've managed to increase the php memory limit
and install the 1.0.9 version, which is great - I've had to reduce the
memory limit after installation, but I'm hoping this won't affect
performance, and we'll be able to start testing the catalogue properly
now.

Thanks again,
Helen

Mauricio Adriano

unread,
May 13, 2016, 2:07:12 PM5/13/16
to ICA-AtoM Users, da...@artefactual.com
Hi, I've had the same error, on elasticsearch step of installation:

Loading data


Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to
allocate
32 bytes) in /var/www/atom/lib/model/om/BaseObject.php on line
515

However, the memory limit parameter of my php is 128M... Which would be a viable solution to continue the installation?

Dan Gillean

unread,
May 13, 2016, 2:15:03 PM5/13/16
to ICA-AtoM Users
Hi there Mauricio,

What version of AtoM are you trying to install - 2.2.1? Are you following our default installation instructions (e.g. Ubuntu 14.04, MySQL 5.5+, ES 1.4-1.7, php 5.4+, Nginx webserver, etc), or are you using something different? Are you trying to load existing data, or is this a fresh install? Any other parameters that would be helpful for us to know?

Thanks!

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

--
You received this message because you are subscribed to the Google Groups "ICA-AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To post to this group, send email to ica-ato...@googlegroups.com.
Visit this group at https://groups.google.com/group/ica-atom-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/dffb065c-ded7-438b-80ce-29022880a515%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

raddao...@gmail.com

unread,
May 13, 2016, 2:39:29 PM5/13/16
to ICA-AtoM Users
Hi Mauricio,

That error is actually saying that the 128M are all used and it can't add another 32 bytes. So increasing the memory limit should help with that step, which requires a lot of memory to create and load the intial data to the Elasticsearch index.

Regards.

Mauricio Adriano

unread,
May 13, 2016, 3:02:36 PM5/13/16
to ICA-AtoM Users
Hi Dan.

Follow the informations about our environment.
- SO server: Debian 2.6.32-48 squeeze4
- Version atom being installed: 2.2.1
- Apache Web server + PHP 5.3.3-7
- ES 1.7
- MySQL (in a separate server) 5.5.44

I've tried to follow the instructions exactly as the site (https://www.accesstomemory.org/pt-br/docs/2.2/admin-manual/installation/linux/)...

Dan Gillean

unread,
May 13, 2016, 4:33:39 PM5/13/16
to ICA-AtoM Users
Hi Mauricio,

It looks like Radda has provided an answer for you. If possible, I would try to add more memory, even if only temporarily. Best of luck!

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

Reply all
Reply to author
Forward
0 new messages