500 internal server error...

102 views
Skip to first unread message

BrzI Channel

unread,
Dec 13, 2021, 6:20:28 PM12/13/21
to AtoM Users
Hi folks,
I can log in to my AtoM instance and view all pages except the users page. I get 500 internal server error.
Nginx log shows:
2021/12/13 15:02:06 [error] 1381#1381: *3730 FastCGI sent in stderr: "PHP message: Unknown record property "username" on "QubitRelation"" while reading response header from upstream, client: 112.222.49.148, server: _, request: "GET /index.php/user/list HTTP/1.1", upstream: "fastcgi://unix:/run/php7.2-fpm.atom.sock:", host: "xxxxxxxxxxx", referrer: " xxxxxxxxxxx  /"

Any suggestions ?

Thanks

Vincent Decorges

unread,
Dec 14, 2021, 8:10:02 AM12/14/21
to AtoM Users
Maybe there is some duplicate entries in the table atom.user, can you check that? Some weeks ago, we got a problem that look like the one you describe. Do you have restore the DB recently?

Vincent

BrzI Channel

unread,
Dec 14, 2021, 1:28:51 PM12/14/21
to AtoM Users
Yes I did have a DB restore recently...Did about 3 restores in two days.

Will need to refresh my memory on how to do a query :-)

BrzI Channel

unread,
Dec 14, 2021, 1:50:16 PM12/14/21
to AtoM Users
OK. in the users table I have some accounts that do not make sense..

The following IDs I cannot recognize: 99999, 100000, 100500 and 150000

Untitled.png

If I simply deleted them would that likely fix my problems ?

Thanks

BrzI Channel

unread,
Dec 14, 2021, 4:25:58 PM12/14/21
to AtoM Users
I deleted one of the two "admin2" accounts. Still seeing the 500 error....

What else could I do ?

Thanks

Dan Gillean

unread,
Dec 14, 2021, 4:49:34 PM12/14/21
to ICA-AtoM Users
Hi there, 

If you have loaded backups recently, did you remember to follow similar steps as advised in our Upgrade documentation? That is:
  • Drop and recreate the database
  • Load the backup
  • Run the upgrade task
  • Clear the cache, restart services, and re-index
See step 4 and onwards in this section of the Upgrading guide: 
Doing so is the best way to ensure that the database schema used in the backup matches the one in the installation. We sometimes see errors like this when people forget to run the upgrade task as part of their upgrade procedure. 

Let us know if that helps! 

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/f4cb8c24-899b-4780-b04b-6a6cf64c8767n%40googlegroups.com.

BrzI Channel

unread,
Dec 14, 2021, 6:14:29 PM12/14/21
to AtoM Users
I did not drop and recreate the database when I imported the backup.
I did not run the upgrade task when I imported the backup.
etc...

I simply imported the backup file and nothing else..not sure if I need to run the upgrade task though...?

Guess I have my work cut out for me :-)

Thanks

Dan Gillean

unread,
Dec 15, 2021, 9:27:02 AM12/15/21
to ICA-AtoM Users
Make sure you still have a copy of the backup outside of AtoM, but if so, then yes I would suggest you try those steps now and see if it helps to resolve the issue. 

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him

Vincent Decorges

unread,
Dec 20, 2021, 2:55:16 AM12/20/21
to AtoM Users
The issue come on my side because we copy the productive data to a test database without the users information. So the relation between the tables object and user were wrong. You can see if this is the case on your installation with this query:
select * from atom.user, atom.object where user.id = object.id and class_name <> "QubitUser";

Dan Gillean

unread,
Dec 20, 2021, 10:40:31 AM12/20/21
to ICA-AtoM Users
Thanks for sharing what worked for you, Vincent! 

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him

BrzI Channel

unread,
Jan 5, 2022, 4:24:06 PMJan 5
to AtoM Users
Hi folks,

took a while to get back to this (thanks to log4j) but today I deleted all the unknown user accounts. The user page is now visible.

Issue resolved. Happy New Year all.

Thanks
Reply all
Reply to author
Forward
0 new messages