EAD Exports, Part II

Skip to first unread message

Carolyn Sullivan

Mar 31, 2023, 1:59:12 PM3/31/23
to AtoM Users
Hello Dan,

For some reason my responses to the original thread here don't seem to be sending (https://groups.google.com/g/ica-atom-users/c/ADDv9QL6Oz8), so I thought I'd send it via a new conversation.

CLI EAD exports are successful and I'm able to view the exported file.  Also, the code here: https://github.com/artefactual/atom/blob/stable/2.6.x/plugins/sfEadPlugin/modules/sfEadPlugin/templates/indexSuccessHeader.xml.php matches what's in my repository.



Jennifer Roberts

Mar 31, 2023, 3:03:53 PM3/31/23
to AtoM Users
Hi Carolyn!

Thanks for re-posting the bits from your original thread for ease of everyone to follow.  I'm hoping the community might chime in here on some of your issues too.  Dan is amazing (as we all know) and I want to hear more from other AtoM real world users when they experience similar issues and how they tried to resolve them.  

Kind regards,

Jenn Roberts (she/her)
Systems Archivist, Business Development Team

Carolyn Sullivan

Mar 31, 2023, 3:24:32 PM3/31/23
to AtoM Users
A few other notes:

Some of the StackOverFlow threads seem to suggest this error is caused by the addition of whitespace at the start of the doc (see JSP error here: https://stackoverflow.com/questions/15312843/xml-declaration-allowed-only-at-the-start-of-the-document).  I've tried to account for issues of this kind:

(1) Edited
https://github.com/artefactual/atom/blob/stable/2.6.x/plugins/sfEadPlugin/modules/sfEadPlugin/templates/indexSuccessHeader.xml.php to remove the newline between the first and second line, in case for some reason that was being introduced to output before the echo statement was executing --> restarted nginx, memcached, and php7.2-fpm (running version 2.6 on this server), then did php symfony cc.  Didn't work.

  $str = trim(ob_get_clean())
  echo Qubit::tidyXml($str);
... also didn't work. 

I'm going a little crazy trying to figure out where this newline character is coming from... any suggestions would be deeply appreciated!

Dan Gillean

Apr 3, 2023, 11:25:06 AM4/3/23
to ica-ato...@googlegroups.com
Hi again Carolyn, 

First: as to why your messages were bouncing - did you ever formally make an account with this email address in the User Forum? We adjusted the settings so this is not required to post, but in some cases (often when users respond to threads too quickly for the filters, is my best guess) repeated posts will be flagged as spam. I've tried to write up a short FAQ about this here: 
After consulting with one of our developers and looking at some of the links in our previous thread again, one of our developers pointed out the following: 

Please visit the following URLs (one from your site, one from our demo site) and right-click and view the page source from each: 
You will notice that even on a non-export page, there is a blank line of whitespace in source code, which is not present in the default version. I strongly suspect there is something in your custom theme causing this - likely in the header or one of the other layout templates. 

You could try changing back to the default Dominion theme via Admin > Themes, and see if this allows your EAD exports to proceed - this should help us confirm that it's the theme causing the issue. It could also be something on the server side - a specific webserver config or something - so start with this. Hopefully if we can narrow things down, you can go from there. 

Let us know how it goes!

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
he / him

You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/1fca7ecb-8779-4710-83b0-1aa8eb51e2cen%40googlegroups.com.
Reply all
Reply to author
Message has been deleted
Message has been deleted
0 new messages