Skip to first unread message

slawomir...@gmail.com

unread,
Jan 8, 2021, 2:41:20 PM1/8/21
to AtoM Users
Hello,

I have a problem after CSV import (over 900 records). I don't know why, the import wasn't as expected, there was some loop and everything was imported twice. And after that the job was on jobs list for over 2 weeks, so I cleaned the jobs list using

sudo php symfony jobs:clear

All items has been imported (twice, but I can do something with that), but one [Item 26 - Tadeusz Szostak - relacja] is "dead" - there are no attributes, I cant get access to it. I can click on it, but with no effect. I can see link, so I can see the slug, but opening in new tab shows 500 error.

It looks as on the pic below:
atom.zajezdnia.org.png

I can't even delete this Item using GUI, so I want to delete this item in CLI, and after using:

sudo php symfony tools:delete-description tadeusz-szostak-relacja

I've got this:

WARNING: You are about to delete the record "Tadeusz Szostak - relacja" and 0 descendant records.
  Are you sure you want to proceed? (y/N)

y
>> delete-description [11:28:59 AM] Deleting description "Tadeusz Szostak - relacja" (slug: tadeusz-szostak-relacja, +0 descendants)


   [wrapped: Could not build SQL for expression: information_object.LFT > NULL]


I tried to delete whole [Series] 7 using GUI, but I get the 500 error...


What can I do to delete this Item or to clean the Series?


Best regards
Slawomir

slawomir...@gmail.com

unread,
Jan 8, 2021, 3:00:44 PM1/8/21
to AtoM Users
Before I was trying to delete the Item I used the command:

php symfony propel:generate-slugs
php symfony propel:generate-slugs --delete

But there was no effect. The Item is still inactive.



Slawomir

Dan Gillean

unread,
Jan 8, 2021, 4:54:09 PM1/8/21
to ICA-AtoM Users
Hi Slawomir, 

Trying the slug generation task was a good idea - sometimes if a CSV import goes wrong, it can leave incomplete rows in the database, including rows that are missing slugs. However, if your description has a slug you can see in the browser, then this isn't the issue. I'll offer a few suggestions on other things to check or try below. 

First, let's try a few other common troubleshooting tasks that can sometimes clear up these types of issues. 

It's possible that the nested set needs to be rebuilt - this is a method we use in AtoM to manage hierarchical relationships in the flat, table-like structure of a relational database. It is also typically captured in AtoM's database using LFT and RGT columns, so it sounds quite possible that the error you've reported relates to this. If an import times out, sometimes the nested set becomes corrupted, and this can lead to strange loops in the UI, or the appearance of doubles. You can rebuild the nested set with the following: 
I would also suggest that we clear any caches used in AtoM, and try repopulating the search index. First, let's clear the application cache: 
I also recommend restarting PHP-FPM and, if you're using it, Memcached. The command for restarting PHP-FPM will depend on the O/S and PHP version you have installed - for AtoM 2.6 with PHP 7.2 on Ubuntu, the command is typically: 
If you're using Memcached (if you're not sure, you can always try the command - it won't break anything if you don't have it installed), restart that as well: 
Now, let's try to repopulate the search index, and see if that makes the description accessible: 
Remember as well to clear your browser cache before retesting, or else test in a private or incognito browser tab where the cache is typically disabled by default, to ensure that you are seeing up-to-date results! 

If that still doesn't work: 

Any time you get a 500 error, it's helpful to take a look at the webserver logs to learn more about the exact nature of the error. We have information on how to access the Nginx error logs here: 
Feel free to share any relevant error message you find, as this will help our team come up with further suggestions. 

You could also try checking for some of the common forms of data corruption that may have resulted from the aborted import attempt. See this section of our Troubleshooting documentation for more information: 
Start with these suggestions and let us know how it goes! 

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/3cfd5cdb-97f8-48fe-87dd-dea9d514ca1en%40googlegroups.com.

slawomir...@gmail.com

unread,
Jan 8, 2021, 5:43:19 PM1/8/21
to AtoM Users
Dan, thank you!

It works! I can access to the corrupted Item! Everything just works fine.

Thank you very, very much!



Cheers
Sławomir
Reply all
Reply to author
Forward
0 new messages