Elasticsearch log error [i18n.es.authorizedFormOfName.alphasort]

9 views
Skip to first unread message

Jaime Vázquez

unread,
Sep 22, 2022, 8:44:32 PM (6 days ago) Sep 22
to AtoM Users
Hi,

We just installed Atom 2.6.4 and we are getting errors like this one :
[i18n.es.authorizedFormOfName.alphasort  in elasticsearch log.
Sometimes authorizedFormOfName change to name or other expressions.
And when we try to menu linkś we get elasticsearch error.
Any idea?

Thanks in advance.

Saludos
Jaime


Dan Gillean

unread,
Sep 23, 2022, 9:21:48 AM (5 days ago) Sep 23
to ICA-AtoM Users
Hi Jaime, 

First, a few questions about your environment: 
  • What is the full version number listed in Admin > Settings?
  • Did you follow the recommended installation instructions for your version, or have you made changes - and if changes, what? Most importantly, are you using Elasticsearch 5.6 as recommended for version 2.6.4?
  • How much memory does your AtoM installation have allocated?
  • What is the default culture of your installation, set in apps/qubit/config/settings.yml?
  • Do you have Spanish (es) added as an indexed language in Admin > Settings > i18n languages?
  • Have you tried any of the common maintenance tasks to resolve this issue?
  • Are your editors manually typing content, or cutting and pasting it from another source (like a Word document or similar)?
  • Are there any more details in the ES error log message you can share? You have shared a field name, but I don't see the actual error message - if there is any additional information in the logs, please post it for us
A couple initial suggestions as well: 

First, I would suggest that you try simply clearing the application cache, restarting PHP-FPM, and then rebuilding the search index to see if this resolves the issue. Links: 
If that doesn't resolve the issue, I would suggest running the search status task to see if it supplies any useful information - feel free to share the output of the task here. 
There are also a number of threads in the user forum with more advanced Elasticsearch troubleshooting suggestions. See for example: 
Let us know what you find, whether any of the above helped to resolve the issue, and if not, the answers to the questions I asked - hopefully we can then offer additional suggestions. Good luck!

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/2caf590b-4888-45bf-9d17-a25e781c7bf9n%40googlegroups.com.

Jaime Vázquez

unread,
Sep 23, 2022, 9:50:19 AM (5 days ago) Sep 23
to ica-ato...@googlegroups.com
Hi Dan,

El vie, 23 sept 2022 a la(s) 10:21, Dan Gillean (d...@artefactual.com) escribió:
>
> Hi Jaime,
>
> First, a few questions about your environment:
>
> What is the full version number listed in Admin > Settings?
2.6.4 - 184
> Did you follow the recommended installation instructions for your version, or have you made changes - and if changes, what? Most importantly, are you using Elasticsearch 5.6 as recommended for version 2.6.4?
{
"name" : "tMpY95t",
"cluster_name" : "elasticsearch",
"cluster_uuid" : "w6bHTEYDRqOceY_8ISZBvA",
"version" : {
"number" : "5.6.16",
"build_hash" : "3a740d1",
"build_date" : "2019-03-13T15:33:36.565Z",
"build_snapshot" : false,
"lucene_version" : "6.6.1"
},
"tagline" : "You Know, for Search"
}
> How much memory does your AtoM installation have allocated?
Humm ... default
> What is the default culture of your installation, set in apps/qubit/config/settings.yml?
es
> Do you have Spanish (es) added as an indexed language in Admin > Settings > i18n languages?
yessystemctl restart php7.2-fpm.service
> Have you tried any of the common maintenance tasks to resolve this issue?
php symfony cache:clear, php symfony search:populate,
> Are your editors manually typing content, or cutting and pasting it from another source (like a Word document or similar)?
Many imports from csv files
> Are there any more details in the ES error log message you can share? You have shared a field name, but I don't see the actual error message - if there is any additional information in the logs, please post it for us

org.elasticsearch.transport.RemoteTransportException:
[C41Ocb2][local[1]][indices:data/read/search[phase/query]]
Caused by: org.elasticsearch.index.query.QueryShardException: No
mapping found for [i18n.es.title.alphasort] in order to sort on
at org.elasticsearch.search.sort.FieldSortBuilder.build(FieldSortBuilder.java:262)
~[elasticsearch-5.6.16.jar:5.6.16]
at org.elasticsearch.search.sort.SortBuilder.buildSort(SortBuilder.java:156)
~[elasticsearch-5.6.16.jar:5.6.16]
at org.elasticsearch.search.SearchService.parseSource(SearchService.java:634)
~[elasticsearch-5.6.16.jar:5.6.16]
at org.elasticsearch.search.SearchService.createContext(SearchService.java:485)
~[elasticsearch-5.6.16.jar:5.6.16]
at org.elasticsearch.search.SearchService.createAndPutContext(SearchService.java:461)
~[elasticsearch-5.6.16.jar:5.6.16]
at org.elasticsearch.search.SearchService.executeQueryPhase(SearchService.java:257)
~[elasticsearch-5.6.16.jar:5.6.16]
at org.elasticsearch.action.search.SearchTransportService$6.messageReceived(SearchTransportService.java:343)
~[elasticsearch-5.6.16.jar:5.6.16]
at org.elasticsearch.action.search.SearchTransportService$6.messageReceived(SearchTransportService.java:340)
~[elasticsearch-5.6.16.jar:5.6.16]
at org.elasticsearch.transport.RequestHandlerRegistry.processMessageReceived(RequestHandlerRegistry.java:69)
~[elasticsearch-5.6.16.jar:5.6.16]
at org.elasticsearch.transport.TransportService$7.doRun(TransportService.java:662)
[elasticsearch-5.6.16.jar:5.6.16]
at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:675)
[elasticsearch-5.6.16.jar:5.6.16]
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37)
[elasticsearch-5.6.16.jar:5.6.16]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
[?:?]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
[?:?]
at java.lang.Thread.run(Thread.java:829) [?:?]

>

Thank you very much Dan.
Strangely the main page of the site mixes English and Spanish:

Navegar por

Archival descriptions
Authority records
Archival institution
...

If I activate the language menu in the menu, and change to both
English or Spanish, that strange mixture disappears, and the error log
desapear.
Gracias, de nuevo, Dan.

Saludos
Jaime


> A couple initial suggestions as well:
>
> First, I would suggest that you try simply clearing the application cache, restarting PHP-FPM, and then rebuilding the search index to see if this resolves the issue. Links:
>
> Clear cache: https://www.accesstomemory.org/docs/latest/admin-manual/maintenance/clear-cache/
> Restart PHP-FPM: https://www.accesstomemory.org/docs/latest/admin-manual/maintenance/troubleshooting/#restarting-php-fpm
> Populate search index: https://www.accesstomemory.org/docs/latest/admin-manual/maintenance/populate-search-index/
>
Yes, done.
> If that doesn't resolve the issue, I would suggest running the search status task to see if it supplies any useful information - feel free to share the output of the task here.
>
> php symfony search:status

Elasticsearch server information:
- Version: 5.6.16
- Host: localhost
- Port: 9200
- Index name: atom

Document indexing status:
- Accession: 0/0
- Actor: 1066/1066
- Aip: 0/0
- Function object: 0/0
- Information object: 1190/1190
- Repository: 1/1
- Term: 1274/1274
> You received this message because you are subscribed to a topic in the Google Groups "AtoM Users" group.
> To unsubscribe from this topic, visit https://groups.google.com/d/topic/ica-atom-users/B2JmUGT8xSw/unsubscribe.
> To unsubscribe from this group and all its topics, send an email to ica-atom-user...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/CAC1FhZ%2BZVg1OPD9Nh1A8Xtt0NQdrDzNkSZ6ztQhqFVdSpRDr%3Dw%40mail.gmail.com.
Reply all
Reply to author
Forward
0 new messages