AtoM 2.3 Rights Statement Pop-Up

87 views
Skip to first unread message

Mathieu Deschaine

unread,
Jun 21, 2016, 1:11:20 PM6/21/16
to ICA-AtoM Users

Hello AtoM Community,

 

I'm currently doing some playing in AtoM 2.3 and I found something interesting, that isn't necessarily a problem with the app, just something that may be good to be reported.


I've been looking at the Click-Through pop-up rights statement, and I've found that when I'm using Chrome, with the default PDF viewer extension, and the object is a PDF, after clicking "agree" and being sent to the PDF it throws an error and ends up in a reload loop.  



In FF with the Adobe PDF viewer it works fine, and if you disable the PDF viewer extension it downloads fine.  Like I said, it's not really an issue with AtoM, but interesting from a user experience perspective.


-Matt





Dan Gillean

unread,
Jun 21, 2016, 1:16:03 PM6/21/16
to ICA-AtoM Users
Hi Mathieu,

Thank you for this report! I'll try to reproduce this behavior myself today. I do test mostly using FF, but interestingly we developed this feature for a client who primarily uses Chrome. If I can reproduce it, I'll talk to our team and see if there's an easy solution we might be able to implement before the formal public 2.3 release.

I'm glad to hear that there are users testing out some of 2.3's new features already!

Cheers,

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

--
You received this message because you are subscribed to the Google Groups "ICA-AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To post to this group, send email to ica-ato...@googlegroups.com.
Visit this group at https://groups.google.com/group/ica-atom-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/9bef7640-1f9e-478c-b0ae-780aa2e1bb8b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Sara - Artefactual

unread,
Jun 23, 2016, 3:42:12 PM6/23/16
to ICA-AtoM Users
Hi Matt,

I can't seem to replicate this using Chromium on Linux or Chrome on Mac. We'll keep an eye out for it while we continue to test 2.3, though!

Sara

Dan Gillean

unread,
Jun 23, 2016, 4:22:13 PM6/23/16
to ICA-AtoM Users
Hi Mathieu,

I also just gave this a test run using Chrome on Windows 10, and could not reproduce the issue. It's possible it was a minor regression that has since been fixed - you might try doing a git pull --rebase on your development environment? Otherwise, I'm not sure - it could be something about that particular PDF which is malformed, or something particular about your browser. My testing was using Chrome v. 51.0.2704.103 m on Windows 10 (v1511 Build 10586.420).

Thanks again for the report; as Sara mentioned, we'll keep an eye open for this as we continue our testing.

Cheers,

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

--
You received this message because you are subscribed to the Google Groups "ICA-AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To post to this group, send email to ica-ato...@googlegroups.com.
Visit this group at https://groups.google.com/group/ica-atom-users.

Mathieu Deschaine

unread,
Jun 23, 2016, 8:30:49 PM6/23/16
to ICA-AtoM Users
You know, I tried both the git pull --rebase, and a few different PDFs and things seem to be in order.  Sorry for the false alarm. Thanks for taking the time to check it out.

-Matt

Dan Gillean

unread,
Jun 24, 2016, 1:45:04 PM6/24/16
to ICA-AtoM Users
We always appreciate reports like this Matt, especially as we're in the process of preparing a release! Thanks for letting us know, and I'm glad to hear that the situation seems to be resolved.

Cheers,

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

juliet...@gmail.com

unread,
May 25, 2017, 12:25:09 AM5/25/17
to AtoM Users
Hi Dan

I have been experiencing this same thing here - not being able to access PDFs after agreeing to the copyright statement. Ok in FF. Can't quite see what the solution is in this stream

Thanks Juliet

Dan Gillean

unread,
May 25, 2017, 4:15:10 PM5/25/17
to ICA-AtoM Users
Hi Juliet,

In our testing, we found this fixed in our most recent development branch - the last poster (Mathieu) seems to have confirmed this, as he resolved the issue by pulling in our most recent code.

Some initial questions for you:
  • Are you using 2.3.0, or 2.3.1?
  • Have you ensured you have followed all the necessary preconditions outlined in the documentation here?
  • Is the PDF you are accessing uploaded locally, or is it linked externally from a web-available resource?
  • You said "Okay in FF." Does this mean it was working as expected in Firefox? If so, what browser were you using where it didn't work?

Once I have a bit more information, I will try to reproduce it again - but if it is in fact fixed in our upcoming release branch, then the best solution will be to wait until the 2.4 release is publicly available.

Cheers,


Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-users+unsubscribe@googlegroups.com.
To post to this group, send email to ica-atom-users@googlegroups.com.

juliet...@gmail.com

unread,
May 26, 2017, 1:42:38 AM5/26/17
to AtoM Users
Thanks Dan, we are using 2.3 and the files were not opening in Chrome Version 58.0.3029.110 (64-bit).  They were opening in FF 53.0.2 (32-bit) after 'agree' button clicked on copyright statement.  PDF loaded locally. Followed documentation. We are still experimenting with copyright access flows so we may or may not use the copyright pop-up - but it is a good thing!

Dan Gillean

unread,
May 31, 2017, 12:04:23 PM5/31/17
to ICA-AtoM Users
Hi Juliet,

Sorry for the delay. I've just re-tested this in our 2.4 development branch using the same version of Chrome, and it has worked as expected for me. I suspect that the issue you've found has been fixed in our upcoming 2.4 release - the best solution for now will be to upgrade once 2.4 is publicly available.

Regards,

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-users+unsubscribe@googlegroups.com.
To post to this group, send email to ica-atom-users@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages