Can't install atom 2.4.1

57 views
Skip to first unread message

Pro Editor

unread,
Jan 14, 2023, 11:16:04 AM1/14/23
to AtoM Users
Hi All
I'm trying to install atom 2.4.1,  with elasticsearch 5.6 .16, mysql 5.7, php 7.3.31.

the installation stops at Configure search step. 


root@debian10:/var/log/elasticsearch# curl localhost:9200/
{
  "name" : "zuEw8yk",
  "cluster_name" : "elasticsearch",
  "cluster_uuid" : "TYavsG0STeKs4JS7CwWlwg",
  "version" : {
    "number" : "5.6.16",
    "build_hash" : "3a740d1",
    "build_date" : "2019-03-13T15:33:36.565Z",
    "build_snapshot" : false,
    "lucene_version" : "6.6.1"
  },
  "tagline" : "You Know, for Search"
}

root@debian10:/var/log/elasticsearch# php -v
PHP Warning:  PHP Startup: gearman: Unable to initialize module
Module compiled with module API=20170718
PHP    compiled with module API=20180731
These options need to match
 in Unknown on line 0
PHP Warning:  Module 'curl' already loaded in Unknown on line 0
PHP 7.3.31-1~deb10u2 (cli) (built: Dec 15 2022 09:39:10) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.31, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.31-1~deb10u2, Copyright (c) 1999-2018, by Zend Technologies

root@debian10:/var/log/elasticsearch# mysql -V
mysql  Ver 14.14 Distrib 5.7.37, for Linux (x86_64) using  EditLine wrapper
root@debian10:/var/log/elasticsearch#

root@debian10:/var/log/elasticsearch# java -version
java version "1.8.0_171"
Java(TM) SE Runtime Environment (build 1.8.0_171-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.171-b11, mixed mode)



Nabil el filali

unread,
Jan 14, 2023, 11:20:36 AM1/14/23
to AtoM Users
2023-01-14_17h19_03.png

Nabil el filali

unread,
Jan 14, 2023, 11:22:47 AM1/14/23
to AtoM Users
in elasticsearch_deprecation.log, I noticed this warning : 


[2023-01-14T15:44:38,077][WARN ][o.e.d.i.m.TypeParsers    ] field [include_in_all] is deprecated, as [_all] is deprecated, and will be disallowed in 6.0, use [copy_to] instead.
[2023-01-14T15:44:38,077][WARN ][o.e.d.i.m.TypeParsers    ] field [include_in_all] is deprecated, as [_all] is deprecated, and will be disallowed in 6.0, use [copy_to] instead.
[2023-01-14T15:44:38,077][WARN ][o.e.d.i.m.TypeParsers    ] field [include_in_all] is deprecated, as [_all] is deprecated, and will be disallowed in 6.0, use [copy_to] instead.
[2023-01-14T15:44:38,077][WARN ][o.e.d.i.m.TypeParsers    ] field [include_in_all] is deprecated, as [_all] is deprecated, and will be disallowed in 6.0, use [copy_to] instead.

Pro Editor

unread,
Jan 14, 2023, 5:28:42 PM1/14/23
to ica-ato...@googlegroups.com
yeeeeeeees of course


--
You received this message because you are subscribed to a topic in the Google Groups "AtoM Users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/ica-atom-users/7smY5nxZFCc/unsubscribe.
To unsubscribe from this group and all its topics, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/de5d7df4-f289-4bc3-88bc-a963470fd46en%40googlegroups.com.

Dan Gillean

unread,
Jan 17, 2023, 11:09:03 AM1/17/23
to ica-ato...@googlegroups.com
Hi there, 

First, I strongly recommend against installing a release as old as version 2.4.1, which came out in November of 2018. There have been many bug fixes, security patches, dependency upgrades, performance improvements, and new features added to AtoM since. Our most recent release was version 2.7.1, released just last week - see: 
For a list of all the new features and enhancements in release 2.7, see: 
PLEASE consider installing 2.7.1 instead! If you are upgrading from a previous version, please note that you can skip versions - you should be able to upgrade to 2.4.1 from any earlier version from ICA-AtoM 1.2 or later.


In terms of why you encountering errors: 

I strongly suspect it is because you are using the wrong dependencies. 

We version the installation instructions for each major release specifically so that we can independently address dependency version information. Please see the installation instructions for 2.4 (here) - you will note that: 
  • They specifically warn that MySQL 5.7 has not been tested with 2.4.1 and there are known issues
  • That PHP 7.0 should be used - there are known issues in 2.4.1 with PHP 7.1 or higher
  • AtoM 2.4.1 only supports Elasticsearch version 1.7 - we did not add support for ES 5.6 until AtoM 2.5 and later. Elasticsearch regularly introduces breaking changes between major versions and there are a LOT of changes between ES 1.x and 5.x
It also appears that you are using Debian, which you didn't mention in your post. While we have seen our community members successfully install and run AtoM using Debian distributions, we test and develop using Ubuntu Long-term releases. AtoM 2.4.1 is tested and the documentation supports Ubuntu 14.04 and 16.04. 

If you follow the installation instructions and use the recommended dependencies, it should resolve many issues. If you're willing to manage your own troubleshooting, keep using Debian if desired - but at minimum, AtoM likely won't work without the right underlying versions for PHP, MySQL, and Elasticsearch. 

Note that if your post was a typo and you actually meant 2.7.1, then the dependencies are still wrong - AtoM 2.7.1 expects MySQL 8.0 and PHP7.4 for example. 

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/f79e83e4-84b9-41e3-9b02-dd13e5499f0cn%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages