Question about AtoM 2.5 software requirements

34 views
Skip to first unread message

Darryl Friesen

unread,
Jun 17, 2020, 3:38:33 PM6/17/20
to AtoM Users

I'm attempting to build a new AtoM 2.5 server. Because I am a glutton for punishment, I'm building this on RHEL 7 with Puppet. I've been using the gist from Santiago Rodríguez (

He installs Python, pip, and several Python modules (sphinx, sphinxcontrib-httpdomain, sphinx_rtd_theme).  None of this is mentioned in AtoM 2.5's official instructions when installing under Ubuntu.  Is that because these are already available in a base Ubuntu server install?  Is Python (and those listed modules) a requirement for AtoM, and if so, what version should I be installing on my RHEL box?  pip warns me that Python 2.7 is EOL and that I should upgrade.  That implies I should maybe using some version of Python 3, but I'm not sure what version is recommended.

Thanks!

- Darryl

José Raddaoui

unread,
Jun 17, 2020, 4:23:22 PM6/17/20
to AtoM Users
Hi Darryl,

You don't need Python/pip/sphinx for a normal AtoM deploy. AFAIK, they're used for the AtoM documentation repository, so maybe Santiago was creating a development/testing machine.

Best regards.

Darryl Friesen

unread,
Jun 17, 2020, 4:28:27 PM6/17/20
to AtoM Users
Thanks José.  That's great news, because installing a working version of pip on a RHEL 7 machine via Puppet is turning out to be a huge hassle!! I shall just ignore those steps!  :)

- Darryl
Reply all
Reply to author
Forward
0 new messages