Finding aid or XML Generation is failing

33 views
Skip to first unread message

EdderShredder

unread,
Jan 19, 2022, 5:57:15 AMJan 19
to AtoM Users
Hi all.

When exporting a finding aid we are getting an error.

This had been working up until Oct21.

[info] [2022-01-19 02:49:15] Job 70522 "arFindingAidJob": Job started.
[info] [2022-01-19 02:49:15] Job 70522 "arFindingAidJob": Generating finding aid (*edited out)...
[info] [2022-01-19 02:49:16] Job 70522 "arFindingAidJob": Running: java -jar '/usr/share/nginx/atom/lib/task/pdf/saxon9he.jar' -s:'/tmp/php7FYzxt' -xsl:'/usr/share/nginx/atom/lib/task/pdf/ead-pdf-full-details.xsl' -o:'/tmp/php5ja6KN' 2>&1
[info] [2022-01-19 02:49:18] Job 70522 "arFindingAidJob": Transforming the EAD with Saxon has failed.
[info] [2022-01-19 02:49:18] Job 70522 "arFindingAidJob": ERROR(SAXON): Error on line 2 column 1 of php7FYzxt:
[info] [2022-01-19 02:49:18] Job 70522 "arFindingAidJob": ERROR(SAXON): SXXP0003: Error reported by XML parser: Premature end of file.
[info] [2022-01-19 02:49:18] Job 70522 "arFindingAidJob": ERROR(SAXON): Transformation failed: Run-time errors were reported
[info] [2022-01-19 02:49:18] Job 70522 "arFindingAidJob": Job finished.

Also when I try and export EAD 2002 XML it fails with

XML Parsing Error: no element found
Location: *edited out;ead?sf_format=xml
Line Number 2, Column 1:


I have tried various solutions, checked file permissions etc with no luck.
Has anyone any idea?

EdderShredder

unread,
Jan 19, 2022, 6:45:38 AMJan 19
to AtoM Users
I have seen the other finding aid threads and tried the solutions there.
We have created a test fond with no information and it is the same error.

Dan Gillean

unread,
Jan 19, 2022, 11:56:33 AMJan 19
to ICA-AtoM Users
Hi there Ed, 

I've found one similar thread with some suggestions - in case you haven't seen it: 
We most commonly see this type of error when there are unexpected characters in the metadata. For example, including angle brackets (like < and >) in your metadata can cause rendering issues, as these are reserved characters in XML. See: 
Similarly, non UTF-8 content can cause this issue, which can occur if you've copied and pasted content from a non UTF-8 source, such as an MS Word document. In the thread linked above, the issue was likely caused by the non UTF-8 "curly quotes" used in Word being copied into the description, causing transformation issues during parsing. 

You said you created a test fonds - was this test fonds created in the user interface manually by typing? Did it include any reserved special characters?

Does your AtoM installation include any code customizations, such as a custom theme or other custom plugins, that might affect basic functionality?

What is the full version number of your AtoM installation, as shown in Admin > Settings > Global, or returned in the command-line when running the following?
  • php symfony tools:get-version

You might also want to check the webserver logs and the atom-worker logs to see if there's any further information available. Assuming you've followed the recommended installation instructions for the latest version, try: 
  • sudo journalctl -f -u atom-worker
  • sudo tail -f /var/log/nginx/error.log
Finally, since the error occurs so early (line 2 it sounds like), the problem may be with the EAD header. Is your AtoM instance able to connect to the internet, or is it behind a firewall? We've previously seen issues where AtoM's attempt to fetch the EAD 2002 DTD from the Library of Congress URI in the header fails when AtoM is firewalled from the internet. An older workaround that I have not personally tested is described here: 
There are also similar issues being reported accessing LoC, but these typically result in a different error message (a 403 Forbidden error). We have implemented a solution for this in the upcoming AtoM 2.7 release - you can find more information in this recent forum thread: 
Let us know what you find, and hopefully we can provide further suggestions and workarounds. 

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/d3f0198f-aa92-4ccc-8ca1-9bbf25b23805n%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages