Problema With APC

396 views
Skip to first unread message

Augusto Torres

unread,
Jan 12, 2016, 12:12:58 PM1/12/16
to ICA-AtoM Users
Dear Coleagues,
After upgrading php versions from php55 to php56, I have problems to connect on Atom-2.2.0
I'm getting the message missing APC support ( You must have APC installed and enabled to use sfAPCCache class.), but dont exists this feature on this version.
Is it possible run the Atom with php56 versions?
Tks
Augusto

Augusto Torres

unread,
Jan 12, 2016, 1:26:12 PM1/12/16
to ICA-AtoM Users
Finally I installed the PC using the FreeBSD Ports 9  /ports/devel/pecl-APCu, but now queries are sent to an invalid page and does not return the results.
I performed the camendos below that have been successful.
php symfony tools: upgrade-sql
php symfony search: populate
php symfony cc

Dan Gillean

unread,
Jan 12, 2016, 5:46:21 PM1/12/16
to ICA-AtoM Users
Hi Augusto,

I was a bit unclear about your second message - is everything working now? Or are things still broken?

As far as I can see from looking at the APCu page, PAC should work fine with up to PHP 7.0: https://pecl.php.net/package/APCu

Our developers do not anticipate any issues using PHP 5.6 in general - we are mostly using 5.5 in our development currently, but there should not be major breaking changes in version 5.6.

Did you follow our recommended installation instructions? Or have you used something different as part of your installation (for example, using Apache instead of Nginx)? We might need to know more about your installation environment to provide a good answer.

Let us know if things are working, and if not, tell us more about your installation environment!

Cheers,

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

--
You received this message because you are subscribed to the Google Groups "ICA-AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To post to this group, send email to ica-ato...@googlegroups.com.
Visit this group at https://groups.google.com/group/ica-atom-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/95155c7b-4c77-44fc-9271-8cb47c3f4bdc%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Augusto Torres

unread,
Jan 13, 2016, 7:11:31 AM1/13/16
to ICA-AtoM Users
Hi Dan Gillean,
Yes, the things still broken yet!
When I deinstall APCu package, I get this message.
==
Oops! An Error Occurred

Sorry, something went wrong.
The server returned a 500 Internal Server Error.

Try again a little later or ask in the discussion group.
Back to previous page.
==

After reinstall, the first page works, but doesn't work any click, redirecting to invalid page:
look at, please => http://www.cle.unicamp.br/atom-2.2.0/

I'm using Apache24, PHP56, FreeBSD9.
It Was working perfectly with php55, before updatind

[]'s
Augusto

Augusto Torres

unread,
Jan 13, 2016, 9:23:12 AM1/13/16
to ICA-AtoM Users
The problem was gererate from wrong update of php from 5.5.30 to 5.5.31 versions.
I'm coming back to php55 (stable version PHP 5.5.31) and working now (ufffff)
Infortunatelly Atom-2.2.0 doesn't work on php56 versios because of ACPu. Meybe the version 2.2.0 comes with native postgres database included. 
I'm waiting the new version of Atom 2.2.3 test on php56 or newer.
Thanks
Augusto

Dan Gillean

unread,
Jan 13, 2016, 2:24:40 PM1/13/16
to ICA-AtoM Users
Hi Augusto.

I'm glad to hear you have things working for now. I'm wondering if there is something about the use of Apache or FreeBSD that interacts with the PHP version. In any case, I will ask our developers to test 2.3 with PHP 5.6, so we can make sure there are no PHP upgrade issues.

Thanks again for letting us know what you found.

Cheers,

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

Dan Gillean

unread,
Jan 15, 2016, 6:05:59 PM1/15/16
to ICA-AtoM Users
Hi Augusto,

I think I might have figured this out. The short answer is: use APCu with AtoM for newer versions of PHP, instead of APC. For more details on why, and what the difference is, please see this related thread:

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

Augusto Torres

unread,
Jun 1, 2016, 7:08:31 PM6/1/16
to ICA-AtoM Users
Long time later ...
I would like to leave my contribution to the Atom-2.2.x users that this problem was solved by deselecting AP2FILTER (use Apache Filter interface experimental) and reinstall mod_php56-5.6.x package again. Remembering thath I'm using FreeBSD port instalation. All works fine now.
Thanks

Dan Gillean

unread,
Jun 1, 2016, 9:17:23 PM6/1/16
to ICA-AtoM Users
Thanks for sharing what worked for you, Augusto!

Cheers,

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

Reply all
Reply to author
Forward
0 new messages