Issues after migration

27 views
Skip to first unread message

Tim Wise - Admin

unread,
Aug 29, 2022, 8:10:24 PMAug 29
to AtoM Users
Good morning, many thanks to this group.
We have migrated to ATOM 2.6.4.
However our end users issues are reporting a few issues within the interface
after moving to the new version.

See Atom1.png Attachment


 

So usually when I click on the ’99 more’ button I can get the next row of items, it currently doesn’t work. Also the Quick Search Button is currently unavailable as well

 


 

 See Atom2.png attachment.

All of the drop down menus for results aren’t working at all. I cant narrow my fields etc

 


Any idea what could be cause these issues and how to resolve them?


Thanks.


TW

ATOM2.png
ATOM1.png

Dan Gillean

unread,
Aug 30, 2022, 9:07:52 AMAug 30
to ICA-AtoM Users
Hi Tim, 

I'll offer a few general suggestions that should help narrow down the issue, if not resolve it. 

First, let's make sure the upgrade went well. Check the full release version number listed in Admin > Settings. It includes a second version number after the release version - this is the database schema version number. As noted on the 2.6.4 release page, the schema version for the latest release should be version 184 - so your Settings should say 2.6.4 - 184. If it doesn't this typically means that one step of the upgrade process was skipped (usually dropping and recreating the database, or else running the upgrade task after loading your sqldump). If this is the case, you should redo the upgrade process to see if that resolves the issue. Even if it's not the cause of this particular issue, running an AtoM installation with the wrong database schema version can lead to unexpected issues later.

Next, let's try a couple common maintenance tasks to see if it helps. Instructions for all of the following can be found on this page: 
I would suggest you try the following: 
  • Run the build nested set command-line task. Both taxonomy terms and trees of descriptions use a Nested set model to help represent hierarchically arranged relationships in the relatively flat, table-like structure of a relational database. Sometimes this can get corrupted when a long-running operation times out
  • Run the generate slugs command-line task. Similarly, sometimes if long-running operations time out before completing, records can end up without a slug. The CLI task, when run without any options, will only generate new slugs where they are missing for all main entity types in AtoM. I don't *think* this is the cause, but as I said, doing so will not impact anything if all records already have slugs, so we can at least rule that out if so. 
  • Re-populate the search index, clear the application cache, and restart PHP-FPM. These three actions often resolve issues when what's being displayed in your browser doesn't match what's stored in the database. Remember that your web browser also has a cache - it can be good to do your testing in an incognito/private browser window (where the browser cache is typically disabled by default), or clear your browser cache first to make sure you're seeing the latest. 
If none of that helps: 
  • You can try running the search:status task to check that your search index is working as expected. Feel free to share the output here if you're unsure about what it returns. 
  • It's always a good idea to check the webserver error logs to see if there's anything relevant there - though if you're not getting a full 500 error in the user interface, there probably won't be. However, Debug mode might return more useful information if you enable it. In both cases, feel free to share anything relevant you find if you're not sure what to try next. See: https://www.accesstomemory.org/docs/latest/admin-manual/maintenance/troubleshooting/#error-logs-and-debug-mode
  • I don't think it's related to these issues, but it's always a good idea to check the status of the job scheduler's worker (listed at the bottom of this section of the docs), and restarting it if needed. 
  • Check what sort setting you have the sidebar treeview set to use in Admin > Settings > Treeview. If it is set to "Title" or "Identifier - title," I recommend you try changing it to "Manual" instead. Unfortunately there are long-standing known issues with the other sort methods that are difficult to resolve (forum thread here for some context and further links). Manual does not have these issues. If you change the sort setting, try clearing the cache, restarting PHP-FPM, and seeing if that resolves the treeview issue. 
Finally, if you're still stuck after these suggestions, let us know. When doing so, please share any relevant information you learned from your previous troubleshooting attempts (what you tried, what worked and didn't, what you found in any error logs, etc) as well as some further general information about your installation, such as: 
  • What version were you upgrading from?
  • Did you follow the recommended installation instructions, or have you made any changes (and if yes, what changes)?
  • Does your installation have any local customizations, including a custom theme plugin?
  • Does your installation environment meet the suggested minimum hardware recommendations found here? If no, what resources does your installation have instead?
  • Anything else you think it would helpful for us to know
Thanks in advance, and good luck!

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/0dc0a57e-1405-45f9-afc7-1a6f1072d61dn%40googlegroups.com.

Tim Wise

unread,
Aug 31, 2022, 1:03:48 AMAug 31
to ica-ato...@googlegroups.com

Good morning Dan, thanks for the prompt and very complete reply.

Yes we did verify the version and was showing 2.6.4 -184.

 

We than ran

the build nested set command-line task

the generate slugs command-line task

Re-populate the search index, clear the application cache, and restart PHP-FPM

 

A critical step in testing seems to be either clear the browser cache or use incognito mode.

After running these three tasks and using a browser in incognito mode to connect it would appear that our issues

Have been resolve. Just awaiting confirmation from the end user.

 

Thanks for your help.

 

Tim Wise

Tim Wise
IT Support Officer Systems
IT Department

E: tw...@loreto.vic.edu.au
T: 5329 6199

Loreto College
1600 Sturt St, Ballarat, 3350
www.loreto.vic.edu.au

  

Loreto College acknowledge the traditional owners of our land, the Wadawurrung people of the Kulin Nation, whose ancient wisdom and traditions continue to nurture these lands and waterways.

Tim Wise
IT Support Officer Systems
IT Department

E: tw...@loreto.vic.edu.au
T: 5329 6199


This email message (and attachments) may contain information that is confidential to Loreto College Ballarat. If you are not the intended recipient you cannot use, distribute, or copy the message or attachments. In such a case, please notify the sender by return email immediately and erase all copies of the message and attachments. Opinions, conclusions, and other information in this message and attachments, that do not relate to the official business of Loreto College Ballarat, are neither given nor endorsed by Loreto College Ballarat.

Reply all
Reply to author
Forward
0 new messages