Google Groups no longer supports new Usenet posts or subscriptions. Historical content remains viewable.
Dismiss

Dosbox Tasm 1.4 Download _BEST_

1 view
Skip to first unread message

Terina Altmark

unread,
Jan 25, 2024, 2:44:50 PMJan 25
to
<div>I know most people don't use tasm or learn 16-bit assembler anymore, but I am taking a course =) And, it's what we use in our labs (some of our labs have XP on them, just for older software). I do not have any 32-bit OS at home, so thus I need to use some form of emulation.</div><div></div><div></div><div></div><div></div><div></div><div>dosbox tasm 1.4 download</div><div></div><div>DOWNLOAD: https://t.co/sB7tDXTmoj </div><div></div><div></div><div>I can download tasm no problems, but installing with dosbox doesn't seem to work at all. No matter what I try, I continually get "too many subdirectories" error message, and the only option is to escape.</div><div></div><div></div><div>I have tried copying the downloading files directly into the dosbox directory, and installing from there. No dice. I tried mounting the install files on a different location as the destination, again no dice.</div><div></div><div></div><div>In summation, I need some emulation to run tasm (Borland assembly), on a 64-bit system. It has to be tasm, because that is what we are using in class, and many of our examples rely on it, e. g. macros that we use =/ I already tried using other assembler programs, but it got complicated really fast, without the spoon feed macros =)</div><div></div><div></div><div>Here is what I just tried:</div><div></div><div>1. Dosbox installed, and launches and appears to function as expected, so I will assume this part is correct (in C:\dosbox\ directory}</div><div></div><div>2. copied the tasm installer into the C:\dropbox\ directory...as well) The C:\dosbox directory has the following:</div><div></div><div>\Dosbox-0.74</div><div></div><div>\users</div><div></div><div>\tasm</div><div></div><div></div><div></div><div></div><div></div><div></div><div>3. I created a folder named "tasm5" in my C:\ directory</div><div></div><div>4. I mounted as d c:\dosbox\</div><div></div><div>5. I mounted e c:\tasm5\</div><div></div><div>6. move to d:, browse to tasm, and type install.exe.</div><div></div><div>7. I select the source of the installer d: (c:\dosbox\tasm)</div><div></div><div>8. and the destination of the installation e: (c:\tasm5)</div><div></div><div>--"too many subdirectories: Press esc"</div><div></div><div></div><div>After I escape, I can observe that within the folder i created, there is a new folder created by the installer named "tasm5", so inside of c:\tasm5\tasm5", 5 other new directories are created (all empty): bin, doc, examples, include, and lib.</div><div></div><div></div><div>Your mountings are unconventional, and remember that under typical conditions the installer was originally used to install from a floppy drive to a hard drive. I suspect your c:\dosbox folder has multiple subdirectories that a floppy would not, and that is the source of the installer's complaint.</div><div></div><div></div><div>copy all of the files from all three disks to a single directory on your hard disk. mount that directory as your root directory.</div><div></div><div>then run install.exe.</div><div></div><div>it will ask "enter the source drive to use", select "C"</div><div></div><div>it will ask "enter the source path", select "\"</div><div></div><div>then start the installation.</div><div></div><div>you'll end up with a "tasm" directory under the directory where you copied the files.</div><div></div><div>I still use TASM in DOSBox for my 16-bit needs.</div><div></div><div></div><div>For DOSBox I visited the DOSBox download page, and got a copy of the latest version for Windows (when I looked it was 0.74). Then I installed it to the default location suggested by the installer (C:\Program Files (x86)\DOSBox-0.74). Next I downloaded tasm.zip from the link at the bottom of this post, unzipped it, and placed it at the root of my drive (C:\tasm).</div><div></div><div> df19127ead</div>
0 new messages