Supported Postgresql versions

28 views
Skip to first unread message

Bjarni Gunnar Bjarnason

unread,
Mar 22, 2021, 7:45:30 AMMar 22
to i2b2 Install Help
Hello.
According to the information I have, i2b2 officially supports all versions of Postgresql 9.x and soon version 10.x will be officially supported.

Can anyone tell me if support for newer versions of Postgresql are in testing?

The reason I ask is that the last version of Postgres 9.x (9.6) will go out of support in November 2021 and version 10 will go out of support in November 2022.

As our project is going live in Q4 this year, I was hoping to use a major version of Postgresql that would be supported for more than one year from that time.

Thanks in advance.

Best regards,

Bjarni Gunnar Bjarnason

Hugbúnaðarsérfræðingur / Software Specialist

Háskóli Íslands / University of Iceland

Neshagi 16
Mobile +354
888 4778
www.hi.is

Mendis, Michael E.

unread,
Mar 22, 2021, 11:37:32 AMMar 22
to i2b2-ins...@googlegroups.com
Currently we support 9 and 10.   I believe it works with 11.   And I have heard of issues with 12.   We are working on getting i2b2 compatible with newer versions of postgresql.   

Mike



On Mar 22, 2021, at 7:45 AM, Bjarni Gunnar Bjarnason <hibj...@gmail.com> wrote:



        External Email - Use Caution        

--
You received this message because you are subscribed to the Google Groups "i2b2 Install Help" group.
To unsubscribe from this group and stop receiving emails from it, send an email to i2b2-install-h...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/i2b2-install-help/2de8cf3d-5899-4fc0-ac32-71e2be773049n%40googlegroups.com.
The information in this e-mail is intended only for the person to whom it is addressed. If you believe this e-mail was sent to you in error and the e-mail contains patient information, please contact the Mass General Brigham Compliance HelpLine at http://www.massgeneralbrigham.org/complianceline . If the e-mail was sent to you in error but does not contain patient information, please contact the sender and properly dispose of the e-mail.

Please note that this e-mail is not secure (encrypted).  If you do not wish to continue communication over unencrypted e-mail, please notify the sender of this message immediately.  Continuing to send or respond to e-mail after receiving this message means you understand and accept this risk and wish to continue to communicate over unencrypted e-mail. 

Bjarni Gunnar Bjarnason

unread,
Mar 22, 2021, 12:47:16 PMMar 22
to i2b2 Install Help
Hello Mike.
Thank you for the information.

If I would like to help you to get Postgresql 11 officially supported.
Do you have an official testing process that I can use to test i2b2 againt a Postgresql 11 database?

Best regards
Bjarni Gunnar

Jeff Klann

unread,
Mar 30, 2021, 3:23:24 PMMar 30
to i2b2 Install Help
Bjarni, sorry for the slow response, we would love your help to get it officially tested for the next release.

First step would be to install it and try it against the demo database and see if you run into any obvious problems.

Then there are a lot of JUnit tests in the source code it will have to pass, and we additionally have a suite of Selenium tests as well. 

But first let us know what obvious problems you find!
Thanks!
Jeff Klann

Ambreen Zaver

unread,
Mar 31, 2021, 6:02:44 PMMar 31
to i2b2-ins...@googlegroups.com
We are using Postgres 10.14 and I ended up fixing syntax for time intervals in two of the following source scripts:
insert_metadata_demo_V2.sql
insert_metadata_visit_details_V1.sql

We do have a functional instance now. I do look forward to more feedback on postgres support though. 

Ambreen. 


Jeff Klann

unread,
Apr 6, 2021, 1:19:34 PMApr 6
to i2b2 Install Help
Ambreen, want to send us your update (through email or through a Github pull request)? Do you know if you time interval logic is backward compatible with PG 9.x?

Thanks,
Jeff

Ambreen Zaver

unread,
Apr 6, 2021, 7:07:34 PMApr 6
to i2b2-ins...@googlegroups.com
Jeff, 
I have added you as a collaborator on my repo zavera/i2b2-data
I tested my interval logic with PG 9.5 and 9.6 and it seems to work. Have not done thorough testing. 

Ambreen.

Ambreen Zaver

unread,
Apr 6, 2021, 10:41:46 PMApr 6
to i2b2-ins...@googlegroups.com
Jeff, 
I also just created a pull request for i2b2-data.
Please disregard my collaboration request on github. At first I had a private repo for only the two scripts that needed fixing. 

thanks!


Reply all
Reply to author
Forward
0 new messages