HyperSpy 1.4 released

40 views
Skip to first unread message

Francisco

unread,
Sep 4, 2018, 6:39:31 AM9/4/18
to hyperspy-users

We are pleased to announce the release of HyperSpy 1.4. See the changelog for details.


We have also released hyperspy-gui-traitsui 1.1.0 and hyperspy-gui-ipywidgets 1.1.0. It is recommended to upgrade these packages when upgrading HyperSpy to version 1.4.


There is also a new release of HyperSpy Bundle 2018.09.04 for Microsoft Windows. It includes the packages mentioned above and the latest development version of HyperSpyUI. You can download it from the project’s GitHub repository.

Alberto E.

unread,
Sep 4, 2018, 6:42:30 AM9/4/18
to hypersp...@googlegroups.com
Hi,

it seems to me the changelog link its broken.

Cheers,
Alberto.

--
You received this message because you are subscribed to the Google Groups "hyperspy-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to hyperspy-user...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Francisco

unread,
Sep 4, 2018, 6:48:34 AM9/4/18
to hyperspy-users
Thanks Alberto for reporting the issue. The right changelog link is http://hyperspy.org/hyperspy-doc/current/user_guide/what_is_new.html#v1-4

Francisco

Luiz Tizei

unread,
Sep 26, 2018, 6:58:42 AM9/26/18
to hyperspy-users
Hi Francisco,

I just installed Hyperspy on a new system using conda. The version installed is 1.3.1 and not the 1.4.
Should I do something else to get the newest version.

Luiz

Francisco

unread,
Sep 26, 2018, 7:20:09 AM9/26/18
to hyperspy-users
If the platform is win32 in conda that's the lastest version available. To upgrade to 1.4 use pip instead: pip install -U hyperspy

Luiz Tizei

unread,
Sep 26, 2018, 7:37:47 AM9/26/18
to hypersp...@googlegroups.com
it is on ubuntu 18.04.

Francisco

unread,
Sep 26, 2018, 8:26:08 AM9/26/18
to hyperspy-users
In that case there must be a dependency conflict. You could try to update all the packages: conda update --all

Luiz Tizei

unread,
Sep 26, 2018, 8:54:10 AM9/26/18
to hypersp...@googlegroups.com
that was it. Thanks!

Le mer. 26 sept. 2018 à 14:26, Francisco <frande...@gmail.com> a écrit :
In that case there must be a dependency conflict. You could try to update all the packages: conda update --all

--
Reply all
Reply to author
Forward
0 new messages