ValueError when trying to run humann2

13 views
Skip to first unread message

Marie P

unread,
Jan 4, 2020, 9:53:10 AM1/4/20
to HUMAnN Users
Hello,

I used the humann2 tool previously for my clinical-based data analyses. However, when I wanted to use it again a few months later, it did not work anymore. Consequently, I re-installed humann2 and the required databases but I still get the following error message, when I try to run humann2:


Decompressing gzipped file ...



Running metaphlan2.py ........

Traceback (most recent call last):
  File "/miniconda3/bin/humann2", line 11, in <module>
    sys.exit(main())
  File "/miniconda3/lib/python2.7/site-packages/humann2/humann2.py", line 906, in main
    custom_database = prescreen.create_custom_database(config.nucleotide_database, bug_file)
  File "/miniconda3/lib/python2.7/site-packages/humann2/search/prescreen.py", line 93, in create_custom_database
    read_percent=float(line.split("\t")[1])
ValueError: invalid literal for float(): 2|1239|91061|186826|1300|1301|2803


Do you have a bit of advice on what I can do about it?

Thank you very, very much in advance!

Kind regards,

Marie 

Lauren McIver

unread,
Jan 6, 2020, 3:21:06 PM1/6/20
to HUMAnN Users
Hello Marie - It looks like you might possibly have an older version of HUMAnN2 installed with a MetaPhlAn2 version that is not compatible. Would you update to the latest version of HUMAnN2 using either pip or the biobakery conda recipe? I think this should resolve the error you are seeing.

Thanks!
Lauren

--
You received this message because you are subscribed to the Google Groups "HUMAnN Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to humann-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/humann-users/7884383e-37a7-40a4-abcf-76f22306a6e4%40googlegroups.com.

Marie P

unread,
Jan 7, 2020, 3:24:17 PM1/7/20
to HUMAnN Users
Hello Lauren,

thank you very much for your reply! I solved the problem today by removing and re-installing anaconda. Then, I re-installed metaphlan2, humann2 and all databases and now it worked fine!

Thanks again!

All the best,

Marie

To unsubscribe from this group and stop receiving emails from it, send an email to humann...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages