Error in running test file

85 views
Skip to first unread message

yklee

unread,
Jul 13, 2021, 9:40:39 AMJul 13
to hoomd-users
Dear HOOMD users,

I have installed HOOMD with anaconda. After installing hoomd using "conda install -c conda-forge hoomd=*=*gpu* -y", I get error like 
"Traceback (most recent call last):
  File "test.py", line 11, in <module>
    hoomd.run(10e3)
File "/home/yklee/anaconda3/lib/python3.8/site-packages/hoomd/__init__.py", line 201, in run context.current.system.run(int(tsteps), callback_period, callback, limit_hours, int(limit_multiple));
RuntimeError: scan failed on 2nd step: cudaErrorInvalidValue: invalid argument"

It seems like my system doesn't recognize cuda package. But I am using gromacs with gpu package so that I don't get what the problem is. Can anyone give me a hand?

With my regards

Joshua Anderson

unread,
Jul 13, 2021, 12:20:30 PMJul 13
to hoomd...@googlegroups.com
yklee,

What is the output of `nvidia-smi`?
------
Joshua A. Anderson, Ph.D.
Research Area Specialist, Chemical Engineering, University of Michigan
> --
> You received this message because you are subscribed to the Google Groups "hoomd-users" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to hoomd-users...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/hoomd-users/d0594600-ba6a-4d37-85aa-b99bd339b70fn%40googlegroups.com.

Message has been deleted
Message has been deleted

Joshua Anderson

unread,
Jul 13, 2021, 1:39:54 PMJul 13
to hoomd...@googlegroups.com
Chris,

Thanks for the info. So this is affecting more than one user. I'm got deadlines this week so I won't be able to look into this further until next week.

One thing I would try is installing HOOMD in a fresh miniconda or miniforge environment and check to see if that has the same issue. Maybe it is one of the pinned anaconda packages causing the problem?
------
Joshua A. Anderson, Ph.D.
Research Area Specialist, Chemical Engineering, University of Michigan

> On Jul 13, 2021, at 12:57 PM, Chris Jones <chris...@u.boisestate.edu> wrote:
>
> I hope you don't mind if I join in as well. I was having the same issue and same error message after installing hoomd-gpu from anaconda yesterday.
>
> `conda list hoomd` shows `hoomd 2.9.6 gpu_py39h9fc83d0_1 conda-forge`
>
> and `nvidia-smi` shows `NVIDIA-SMI 465.31 Driver Version: 465.31 CUDA Version: 11.3`
> To view this discussion on the web visit https://groups.google.com/d/msgid/hoomd-users/329610a6-e6a3-4d76-8c6e-a89c743818bdn%40googlegroups.com.

Joshua Anderson

unread,
Jul 22, 2021, 6:07:07 AMJul 22
to hoomd...@googlegroups.com
All,

Thanks for the report. I can reproduce this behavior. I do not know what is causing the problem, but the CUDA 10.2 build doesn't seem to trigger it. You can work around this issue with:

conda install "hoomd=2.9.6=gpu_py39he2a7f1f_1"
------
Joshua A. Anderson, Ph.D.
Research Area Specialist, Chemical Engineering, University of Michigan

Joshua Anderson

unread,
Aug 11, 2021, 3:01:42 PMAug 11
to hoomd...@googlegroups.com
All,

This issue is still present in the 2.9.7 release on conda-forge. I do not know what is causing it. The problem does not occur when I build from source. The problem also does not occur with the hoomd v3 beta versions on conda forge.
------
Joshua A. Anderson, Ph.D.
Research Area Specialist, Chemical Engineering, University of Michigan

Reply all
Reply to author
Forward
0 new messages