First failure :(

36 views
Skip to first unread message

Donald Ziesig

unread,
Jun 16, 2018, 2:18:19 PM6/16/18
to Hobo Users
Hi again!

It did not take long :'(.

Gemfile:

gem 'hobo'

bundle install


# rails g hobo:user_model

...
.rvm/gems/ruby-2.5.1/gems/bootsnap-1.3.0/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:32:in
`require': cannot load such file -- erubis (LoadError)

I looked up erubis and it seems to be something to generate html, which
I don't need.  Any workarounds?

Don

Al Chou

unread,
Jun 16, 2018, 3:28:58 PM6/16/18
to hobo...@googlegroups.com
Can you hack on that generator inside the hobo gem?

Al

Sent from my iPhone, please forgive typos and auto-correct!
--
You received this message because you are subscribed to the Google Groups "Hobo Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to hobousers+...@googlegroups.com.
To post to this group, send email to hobo...@googlegroups.com.
Visit this group at https://groups.google.com/group/hobousers.
For more options, visit https://groups.google.com/d/optout.

Donald Ziesig

unread,
Jun 16, 2018, 5:40:03 PM6/16/18
to hobo...@googlegroups.com
Hi Al,

I haven't done it recently, but I could hack on it a few years ago.  I will try it later and let you know for sure.

Don

Ed Gomolka

unread,
Jun 18, 2018, 4:31:39 PM6/18/18
to Hobo Users
Erubis is the ERB template engine that Rails 4 used. Rails 5 replaces Erubis with Erubi. I assume that you are using ERB files to reference your Angular code, in which case I don't see how you can avoid it.

Ignacio Huerta

unread,
Jun 20, 2018, 2:21:46 PM6/20/18
to hobousers
Hi Donald,

You can try this branch in your Gemfile. We took some steps to replace Erubis. I also fixed a couple of small bugs today so at least "rails g hobo:user_model" worked in a vanilla Rails 5.2 app:

gem 'hobo', git: 'https://github.com/Hobo/hobo.git', :branch => 'rails5_new2'


--
You received this message because you are subscribed to the Google Groups "Hobo Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to hobousers+unsubscribe@googlegroups.com.

To post to this group, send email to hobo...@googlegroups.com.
Visit this group at https://groups.google.com/group/hobousers.
For more options, visit https://groups.google.com/d/optout.



--
+45 42 997 196

Donald Ziesig

unread,
Jun 20, 2018, 4:03:14 PM6/20/18
to hobo...@googlegroups.com
Hi Ingacio!

Thanks!

The rails g hobo:user_model worked correctly, but when I used

hobo generate migration

I got the following error:

from /home/donz/.rvm/gems/ruby-2.5.1/bundler/gems/hobo-c5cc79192865/hobo_fields/lib/generators/hobo/migration/migration_generator.rb:47:in `migrate'
/home/donz/.rvm/gems/ruby-2.5.1/bundler/gems/hobo-c5cc79192865/hobo_fields/lib/generators/hobo/migration/migration_generator.rb:94:in `migrations_pending?': undefined method `migrations' for ActiveRecord::Migrator:Class (NoMethodError)

This was on a brand new rails api app created with

rails new hoboNtrak --api

added the gem from github in Gemfile, then

bundle install => ran successfully

then

rails g hobo:user_model => ran successfully

At this point I have a copy of user.rb that looks pretty much like the ones in the original apps, but with no appropriate db tables.  This is when I ran

hobo generate migration => got the above error traceback.

also tried

rails generate hobo:migration => got the same error.

Thanks again,

Don
To unsubscribe from this group and stop receiving emails from it, send an email to hobousers+...@googlegroups.com.

Ignacio Huerta

unread,
Jun 21, 2018, 1:37:17 AM6/21/18
to hobousers
Thanks for the testing Donald! I'm afraid there are still quite a few steps pending to upgrade Hobo.

I will try to find some time to continue with this. Volunteers are welcome :).

Warm regards,
Ignacio

Ed Gomolka

unread,
Jul 6, 2018, 8:09:26 PM7/6/18
to Hobo Users
I spent some time today trying to retrofit the new Hobo branch into an existing Hobo application, but I think that is too ambitious at this point. I will try adding it to a Rails 5.2 application and see where that leads me.
To unsubscribe from this group and stop receiving emails from it, send an email to hobousers+...@googlegroups.com.

To post to this group, send email to hobo...@googlegroups.com.
Visit this group at https://groups.google.com/group/hobousers.
For more options, visit https://groups.google.com/d/optout.



--
+45 42 997 196
--
You received this message because you are subscribed to the Google Groups "Hobo Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to hobousers+...@googlegroups.com.

To post to this group, send email to hobo...@googlegroups.com.
Visit this group at https://groups.google.com/group/hobousers.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Hobo Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to hobousers+...@googlegroups.com.

To post to this group, send email to hobo...@googlegroups.com.
Visit this group at https://groups.google.com/group/hobousers.
For more options, visit https://groups.google.com/d/optout.
Reply all
Reply to author
Forward
0 new messages