ANN: hledger-1.33.1

0 views
Skip to first unread message

Simon Michael

unread,
May 2, 2024, 7:18:25 AMMay 2
to hle...@googlegroups.com

2024-04-18 hledger-1.33.1

hledger 1.33.1

  • process >=1.6.19.0 seems not strictly needed and is no longer required,
    improving installability.

  • print and close now show a trailing decimal mark on cost amounts also,
    when needed to disambiguate a digit group mark.

  • The balance commands' HTML output now includes digit group marks when
    appropriate (fixes a regression in 1.25).

  • The add command no longer shows ANSI escape codes in terminals that
    don't support them.

  • Doc updates:

    • import: Skipping -> Date skipping, discuss commodity styles more
    • csv: Amount decimal places: expand, note import behaviour

hledger-ui 1.33.1

  • Require vty-windows-0.2.0.2+ to avoid display problems in recent
    MS Terminal on Windows.

  • process >=1.6.19.0 seems not strictly needed and is no longer required,
    improving installability.

hledger-web 1.33.1

  • Support base64 >=1.0

Reply all
Reply to author
Forward
0 new messages