Bump required GHC version from 8.10 to 9.4 ?

4 views
Skip to first unread message

Simon Michael

unread,
Dec 8, 2023, 11:13:20 AM12/8/23
to hledger
> I see vty-windows is requiring GHC 9.4.4+. I'm thinking about this for hledger. It would be pleasant, but a big jump from 8.10 which I think would hurt our packageability ? Debian stable has 9.0 but Debian unstable has 9.4. No Ubuntu version has a GHC newer than 9.0. But I guess it wouldn't be the end of the world. 8.10 is 3.5y old (2020) and 9.4 is 1y old (2022).


Would requiring GHC 9.4.4+ to build new versions of hledger cause problems for anyone ? Let me know.
Reply all
Reply to author
Forward
0 new messages