Strange PHP FPM startup problem / php5-fpm hangs

354 views
Skip to first unread message

Jonas Genannt

unread,
Aug 21, 2012, 4:13:41 AM8/21/12
to highload-php-en
Hi!

I have an strange php fpm startup problem. I'm using PHP 5.3.14 on
Debian Squeeze and all is fine.

I have now updated to 5.3.16. With 5.3.16 the init script hangs.

I start PHP5 FPM via:

/usr/sbin/php5-fpm --fpm-config /etc/php5/fpm/php-fpm.conf

All pools are started and working, but the php5-fpm does not detach:

/usr/sbin/php5-fpm --fpm-config /etc/php5/fpm/php-fpm.conf

and here it hangs. ctrl +c does not work.

strace tells me:
Process 15949 attached - interrupt to quit
futex(0x7fb923e8ce40, FUTEX_WAIT_PRIVATE, 2, NULL

I have also tested 5.3.15 but it has got the same problem like
5.3.16.

Switching back to 5.3.14 and the php5-fpm detach correctly.

So my configuration works great on .14 but not on .15 and above.

Does anybody know that's going wrong here?

Thanks,
Jonas


Aleksandar Lazic

unread,
Aug 21, 2012, 10:30:11 AM8/21/12
to highloa...@googlegroups.com
Hi,

same problem here.


./configure --prefix=/<prefix>/ --enable-fpm --enable-bcmath --with-bz2
--enable-calendar --with-curl --enable-dba --enable-exif --enable-ftp
--enable-gd-native-ttf --with-jpeg-dir --with-png-dir --with-t1lib
--with-freetype-dir --with-gettext --enable-mbstring --with-mcrypt
--with-mhash --with-mysql=mysqlnd --with-mysqli=mysqlnd
--with-pdo-mysql=mysqlnd --enable-mysqlnd --with-openssl
--with-pcre-regex --with-pspell --enable-shmop --enable-soap
--enable-sockets --enable-sysvmsg --enable-wddx --with-xsl --enable-zip
--with-zlib --with-tcadb --with-openssl-dir --with-gd

###
bin/php -v
PHP 5.4.5 (cli) (built: Aug 8 2012 01:03:00)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies
###

root@Ubuntu-1204-precise-64-minimal ~ # strace -fveall -p 2590 -p 2589
Process 2590 attached - interrupt to quit
Process 2589 attached - interrupt to quit
[pid 2589] wait4(-1, <unfinished ...>
[pid 2590] futex(0x7fc2a4d73720, FUTEX_WAIT_PRIVATE, 2, NULL
###

BR
Aleks

Jonas Genannt

unread,
Aug 27, 2012, 3:55:24 PM8/27/12
to highload-php-en
Hi!

2012/8/21 Jonas Genannt <jonas....@googlemail.com>
> and here it hangs. ctrl +c does not work.
>
> strace tells me:
> Process 15949 attached - interrupt to quit
> futex(0x7fb923e8ce40, FUTEX_WAIT_PRIVATE, 2, NULL
>
> I have also tested 5.3.15 but it has got the same problem like
> 5.3.16.

I have opened an bug on php: https://bugs.php.net/bug.php?id=62954

Please add comments to bug if the bug affects also you :)

Thanks,
Jonas
Reply all
Reply to author
Forward
0 new messages