Issue with J16 pin control with Thetis V2.9.0.8-HL2 Beta 5

108 views
Skip to first unread message

Bruce Schober

unread,
Aug 31, 2023, 3:45:34 PM8/31/23
to Hermes-Lite
I am using the J16 OC Control pins to set the output filter on my XPA125B transmitter.   I noticed that Thetis V2.9.0.8-HL2 Beta 3 was not setting the pins correctly when receiving below 30M.  J16 pin 4 is set (20M/30M in my setup) is active when pins 1, 2, or 3 should be active.  I also see this problem on Beta 5.  I did not check Beta 4.  I did not see it on Beta 1 or 2.  

When I initially installed Beta 5, the J16 pin settings worked correctly.  At some point the behavior changed to the above behavior. 

I am setting the transmit and receive pin settings the same so I don't have any timing problems setting the XPA125B band on transmit. This behavior has caused the band filter setting to be unreliable when transmitting below 30M.  I tried changing RF and MOX delays to no effect.

Here are some screen shot of the pin states for 40M.  The first is transmitting, the second is receiving.

Thanks,

Bruce
KO4PRE



2023-08-31 (8).png
2023-08-31 (6).png

Reid Campbell

unread,
Sep 4, 2023, 4:18:04 AM9/4/23
to herme...@googlegroups.com
Hi Bruce,

Sorry, your email made it into my spam filter, which happens every so often.

There was a change were if Rx2 was enabled the higher frequency of VFO A or VFO B was used to select the LPF in receive but during transmit, the correct filter will be chosen.

Would that tie up with what you are seeing?

Cheers 

Reid
Gi8TME/Mi0BOT
--
You received this message because you are subscribed to the Google Groups "Hermes-Lite" group.
To unsubscribe from this group and stop receiving emails from it, send an email to hermes-lite...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/hermes-lite/90c04450-b814-43dd-a849-c70e93ea50e3n%40googlegroups.com.

Reply all
Reply to author
Forward
0 new messages