Re: Hector Latest version - support for Local_One Consistency CL

45 views
Skip to first unread message

Lewis John Mcgibbney

unread,
Mar 17, 2014, 6:01:14 AM3/17/14
to hector...@googlegroups.com
You could check out the 1.1-4 tag source and patch it with the relevant issue, generate the jar artifact and disseminate + replace it with the existing ones you have in your cluster.


On Mon, Mar 17, 2014 at 8:16 AM, Gaurav Yadav <er.gaura...@gmail.com> wrote:

Hi,

 

I am running into an issue on one of my cassandra cluster's and want to try out Local_one Consistency Level, as I think it might help me in resolving the issue.

 

But, the latest released Hector Core is 1.1-4, which does not support LOCAL_ONE:

https://github.com/hector-client/hector/blob/ed887c97a1e05085dfc460e0ff2dab2ddc2e55b4/core/src/main/java/me/prettyprint/hector/api/HConsistencyLevel.java

 

The next version does support LOCAL_ONE, but hasn’t been released yet:

https://github.com/hector-client/hector/blob/master/CHANGELOG

 

So, is there a way I can use Local_one Consistency level.



--
Thanks & Regards
Gaurav Yadav


DISCLAIMER: This e-Mail may contain proprietary and confidential information and Is sent for the intended recipient(s) only. If by an addressing or Transmission error this mail has been misdirected to you, you Are requested to delete this mail immediately. You are also hereby Notified that any use, any form of reproduction, dissemination, Copying, disclosure, modification, distribution and/or publication Of this e-mail message, contents or its attachment other than by Its intended recipient/s is strictly prohibited.

--
You received this message because you are subscribed to the Google Groups "hector-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to hector-dev+...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Lewis

Peter Lin

unread,
Mar 17, 2014, 9:27:53 AM3/17/14
to hecto...@googlegroups.com, hector...@googlegroups.com, er.gaura...@gmail.com

I've been using 1.1-5 for a while now and it's stable.

I build it myself from source using my fork. the Latest also supports CQL3 and Cassandra 2.0.4 libs
Reply all
Reply to author
Forward
0 new messages