Haste 0.5 released

97 views
Skip to first unread message

Anton Ekblad

unread,
Aug 4, 2015, 6:11:04 PM8/4/15
to haste-compiler
Haste 0.5.0 is now available on Hackage as well as from http://haste-lang.org/downloads!

Unfortunately, this release does *not* bring proper support for GHC 7.10. It does, however, support being used together with GHC 7.10 when built with GHC 7.8, so even if you're an exclusive 7.10 user, the pre-built packages from the website should work just fine!

Being a new major release, 0.5.0 contains some backwards incompatible changes to haste-lib. Hopefully, the improvements they bring will be enough to counteract the initial inconvenience.

Highlights for this release:

* Overhaul of several DOM APIs.
* Significantly improved performance in generated code.
* Compilation is now several times faster than with 0.4 branch.
* Overhauled, optimized and improved Haste.Foreign.
* New APIs for JSStrings, regexes, animation frames, HTML5 audio, and performance timers.
* Decoupling from GHC: Haste versions built using GHC 7.8 can now be used alongside GHC 7.6, 7.10, etc.
* Compilation pipeline broken out into independent ghc-simple library [1] in an attempt to make the GHC API more accessible to other projects.
* User-friendly installer for Windows, taking care of %PATH% setup. Apparently, students were having problems with this when Haste was used for teaching.
* haste-pkg is now a properly patched ghc-pkg, not a fragile wrapper script.
* haste-inst renamed to haste-cabal, to better reflect its use.
* A whole lot of bug fixes, as usual.

That's a lot of stuff for one release, but it's been a while since the last one so...


/Anton

Сергей Скупой

unread,
Aug 6, 2015, 8:56:17 AM8/6/15
to haste-compiler
Archlinux x86-64. Got error:

$ haste-boot
Downloading base libs from GitHub
Sending:
GET /haste-libs/haste-libs-0.5.0.tar.bz2 HTTP/1.1


Creating new connection to valderman.github.io
Received:
HTTP/1.1 200 OK 
Server: GitHub.com
Content-Type: application/octet-stream
Last-Modified: Tue, 04 Aug 2015 22:13:35 GMT
Access-Control-Allow-Origin: *
Expires: Wed, 05 Aug 2015 18:34:36 GMT
Cache-Control: max-age=600
Content-Length: 744539
Accept-Ranges: bytes
Date: Thu, 06 Aug 2015 12:32:19 GMT
Via: 1.1 varnish
Age: 0
Connection: keep-alive
X-Served-By: cache-fra1235-FRA
X-Cache: HIT
X-Cache-Hits: 1
X-Timer: S1438864339.889448,VS0,VE93
Vary: Accept-Encoding


Reading package info from "libraries/rts.pkg" ... done.
Resolving dependencies...
Configuring ghc-prim-0.3.0.0...
cabal: /tmp/1957747793424238335.o: does not exist
Command '/home/sergey/.cabal/bin/haste-cabal' failed with error  code 1

 I tried GHC-7.8.[2-4].  With older versions it's OK, but 0.5 throws the error. Does anybody know what's the problem?

Anton Ekblad

unread,
Aug 6, 2015, 5:55:29 PM8/6/15
to haste-compiler
Interesting; do you get the same error if you build from https://github.com/valderman/haste-compiler and run `haste-boot --force --local` in the root of the repo? Haven't seen this one before.

/Anton

--
You received this message because you are subscribed to the Google Groups "haste-compiler" group.
To unsubscribe from this group and stop receiving emails from it, send an email to haste-compile...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Сергей Скупой

unread,
Aug 7, 2015, 2:33:07 AM8/7/15
to haste-compiler
  Yes, I tried a lot of things, install and reinstall. I removed ~/.cabal ~/.ghc ~/.haste, but haste-boot shows me the same error (only for 0.5 version). I do not exclude it is my Archlinux problem :). At this time pre-booted binary is a rescue. 

пятница, 7 августа 2015 г., 0:55:29 UTC+3 пользователь Anton Ekblad написал:

Dave Compton

unread,
Aug 7, 2015, 9:52:12 PM8/7/15
to haste-compiler
Thanks Anton,

I'm seeing 9 failures (53/62 tests pass) when I run the test suite.  Is that to be expected?  I'm running ghc 7.10.2

Here, for example is the last failure:

Running test ZipWithInfinity...
  GHC disagrees with hastec output!
  GHC says '', but hastec says '[1,1]
()'
  GHC disagrees with hastec -O2 output!
  GHC says '', but hastec says '[1,1]
()'

53/62 succeeded

- Dave

Dave Compton

unread,
Aug 8, 2015, 12:25:02 AM8/8/15
to haste-compiler
If I run the same tests with ghc 7.8.4 I get no failures.

Anton Ekblad

unread,
Aug 8, 2015, 4:25:56 AM8/8/15
to haste-compiler
Yes, test failures like this are expected with GHC 7.10. What you're seeing is essentially GHC 7.10 failing to even compile test cases written for 7.8 (not surprising, since the test cases haven't been vetted for 7.10 compatibility yet), while Haste, being built on 7.8, manages just fine.

/Anton

--
Reply all
Reply to author
Forward
0 new messages