Minor GHC 6.12 with HJScript

3 views
Skip to first unread message

stepcut

unread,
Dec 19, 2009, 3:24:59 PM12/19/09
to Haskell Server Pages
Hello,

When attempting to build HJScript with GHC 6.12, users are
encountering the following error:
--------------------------------
Downloading HJScript-0.4.4...
Configuring HJScript-0.4.4...
Preprocessing library HJScript-0.4.4...
Building HJScript-0.4.4...

src/HJScript/Lang.hs:30:4: parse error on input `rec'
cabal: Error: some packages failed to install:
HJScript-0.4.4 failed during the building phase. The exception was:
ExitFailure 1
happstack-0.4 depends on HJScript-0.4.4 which failed to install.
hsp-0.4.5 depends on HJScript-0.4.4 which failed to install.
-------------------------------

The reported fix is:

<burp> you can safely remove "{-# OPTIONS_GHC -fglasgow-exts #-}" in
Lang.hs
<burp> which enables -XDoRec, "rec" as a keyword

I am planning to release happstack 0.4 on hackage later today. This is
the only issue that prevents users from being able to cabal install
happstack from hackage under 6.12.

thanks!
- jeremy

Aycan iRiCAN

unread,
Dec 20, 2009, 7:03:23 PM12/20/09
to Haskell Server Pages
Actually you also need -XGADTs.

aycan@fgt:~/haskell/HJScript-0.4.5$ head -n1 src/HJScript/Monad.hs
{-# LANGUAGE OverlappingInstances, UndecidableInstances, GADTs #-}

Niklas Broberg

unread,
Dec 22, 2009, 9:46:25 AM12/22/09
to haskell-se...@googlegroups.com
> Actually you also need -XGADTs.

Indeed you do, I wonder why that didn't bite me before I uploaded. Oh
well, 0.4.6 is now on hackage with GADTs specified properly. Thanks
for reporting!

Cheers,

/Niklas

Reply all
Reply to author
Forward
0 new messages