Installing Hakyll on MacOS

34 views
Skip to first unread message

objact

unread,
May 6, 2021, 1:51:17 PMMay 6
to hakyll
Hi, I am in the first year of my CS undergrad. We are learning Haskell at university right now and I am trying to install Hakyll to create a blog. I am using cabal 3.4.0.0, MacOS BigSur 11.2.2 and GHCi 9.0.1. When I try to run cabal new-install hakyll I get the following error message: 

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: hakyll-4.14.0.0 (user goal)
[__1] trying: hakyll:+usepandoc
[__2] next goal: pandoc (dependency of hakyll +usepandoc)
[__2] rejecting: pandoc-2.13, pandoc-2.12 (conflict: hakyll +usepandoc =>
pandoc>=2.11 && <2.12)
[__2] trying: pandoc-2.11.4
[__3] next goal: haddock-library (dependency of pandoc)
[__3] rejecting: haddock-library-1.10.0 (conflict: pandoc =>
haddock-library>=1.8 && <1.10)
[__3] trying: haddock-library-1.9.0
[__4] next goal: base (dependency of hakyll)
[__4] rejecting: base-4.15.0.0/installed-4.15.0.0 (conflict: haddock-library
=> base>=4.5 && <4.15)
[__4] skipping: base-4.15.0.0 (has the same characteristics that caused the
previous version to fail: excluded by constraint '>=4.5 && <4.15' from
'haddock-library')
[__4] rejecting: base-4.14.1.0, base-4.14.0.0, base-4.13.0.0, base-4.12.0.0,
base-4.11.1.0, base-4.11.0.0, base-4.10.1.0, base-4.10.0.0, base-4.9.1.0,
base-4.9.0.0, base-4.8.2.0, base-4.8.1.0, base-4.8.0.0, base-4.7.0.2,
base-4.7.0.1, base-4.7.0.0, base-4.6.0.1, base-4.6.0.0, base-4.5.1.0,
base-4.5.0.0, base-4.4.1.0, base-4.4.0.0, base-4.3.1.0, base-4.3.0.0,
base-4.2.0.2, base-4.2.0.1, base-4.2.0.0, base-4.1.0.0, base-4.0.0.0,
base-3.0.3.2, base-3.0.3.1 (constraint from non-upgradeable package requires
installed instance)
[__4] fail (backjumping, conflict set: base, haddock-library, hakyll)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: pandoc, hakyll, base,
hakyll:usepandoc, haddock-library, pandoc:setup.Cabal

I am a newbie when it comes to coding, so any help is greatly appreciated. Thank you very much! :D

Laurent P. René de Cotret

unread,
May 6, 2021, 3:22:22 PMMay 6
to hak...@googlegroups.com

Hello,

 

This error message means that you cannot build hakyll using GHC 9.0.1, which is bundled with base-4.15.

 

You need to “downgrade” to GHC 8.10, which is bundled with base-4.14

 

Laurent

--
You received this message because you are subscribed to the Google Groups "hakyll" group.
To unsubscribe from this group and stop receiving emails from it, send an email to hakyll+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/hakyll/6442b890-4909-487f-b9cd-fb62c173dda4n%40googlegroups.com.

 

objact

unread,
May 6, 2021, 3:56:58 PMMay 6
to hakyll
Okay, I will do that. Thank you very much!
Reply all
Reply to author
Forward
0 new messages