Package dependency problems during installation

41 views
Skip to first unread message

yu716...@student.lu.se

unread,
Mar 29, 2019, 10:11:03 AM3/29/19
to hakyll
Hi,

I tried to install Hakyll using stack and got the following messages:

~ stack install hakyll                              




Error: While constructing the build plan, the following exceptions were encountered:




In the dependencies for asn1-encoding-0.9.5:


    hourglass must match >=0.2.6, but the stack configuration has no specified version  (latest matching version is 0.2.12)


needed due to hakyll-4.12.4.0 -> asn1-encoding-0.9.5




In the dependencies for asn1-types-0.3.2:


    hourglass needed, but the stack configuration has no specified version  (latest matching version is 0.2.12)


needed due to hakyll-4.12.4.0 -> asn1-types-0.3.2




In the dependencies for deepseq-1.3.0.2:


    base-4.11.1.0 from stack configuration does not match >=4.3 && <4.8  (latest matching version is 4.7.0.2)


needed due to hakyll-4.12.4.0 -> deepseq-1.3.0.2




In the dependencies for haddock-library-1.6.1:


    base-4.11.1.0 from stack configuration does not match (>=4.5 && <4.13) && >1 && <1


needed due to hakyll-4.12.4.0 -> haddock-library-1.6.1




In the dependencies for transformers-compat-0.6.2:


    transformers-0.5.5.0 from stack configuration does not match >=0.3 && ==0.2.*


needed due to hakyll-4.12.4.0 -> transformers-compat-0.6.2




In the dependencies for unix-time-0.3.8:


    old-time needed, but the stack configuration has no specified version  (latest matching version is 1.1.0.3)


needed due to hakyll-4.12.4.0 -> unix-time-0.3.8




In the dependencies for x509-1.7.4:


    asn1-parse must match >=0.9.3 && <0.10, but the stack configuration has no specified version  (latest matching version is 0.9.4)


    hourglass needed, but the stack configuration has no specified version  (latest matching version is 0.2.12)


    pem must match >=0.1, but the stack configuration has no specified version  (latest matching version is 0.2.4)


needed due to hakyll-4.12.4.0 -> x509-1.7.4




In the dependencies for x509-store-1.6.6:


    pem must match >=0.1 && <0.3, but the stack configuration has no specified version  (latest matching version is 0.2.4)


needed due to hakyll-4.12.4.0 -> x509-store-1.6.6




In the dependencies for x509-system-1.6.6:


    pem must match >=0.1 && <0.3, but the stack configuration has no specified version  (latest matching version is 0.2.4)


needed due to hakyll-4.12.4.0 -> x509-system-1.6.6




In the dependencies for x509-validation-1.6.10:


    hourglass needed, but the stack configuration has no specified version  (latest matching version is 0.2.12)


    pem must match >=0.1, but the stack configuration has no specified version  (latest matching version is 0.2.4)


needed due to hakyll-4.12.4.0 -> x509-validation-1.6.10




Some different approaches to resolving this:




  * Consider trying 'stack solver', which uses the cabal-install solver to attempt to find some working build configuration. This can be


    convenient when dealing with many complicated constraint errors, but results may be unpredictable.




  * Build requires unattainable version of base. Since base is a part of GHC, you most likely need to use a different GHC version with the


    matching base.




Plan construction failed.



I am using ghc-8.4.2. Any help will be appreciated.

Sincerely,
Yu

Nick B

unread,
Mar 30, 2019, 11:21:57 AM3/30/19
to hakyll
Bit hard to say without your Cabal file and stack.yaml (or the global one).

This definitely works (and brings hakyll-4.12.4.0, though note it's ghc-8.4.3) though:

stack new --resolver lts-12.12 hakyll-test hakyll-template
cd hakyll
-test
stack build

Reply all
Reply to author
Forward
0 new messages