I love Habari, now how to get it to work on php 5.2.14

29 views
Skip to first unread message

Brandon

unread,
Jan 11, 2016, 3:30:59 PM1/11/16
to habari-dev
Hi There,

I uploaded the requirements.php to my website site and it said

"Your system is ready for Habari 0.8!"


I thought great, I loaded in on my local sever and started playing with it and I love it. For a person who knows how to code it is very simple and easy to use. I do not have to spend hours figuring out how to work around an interface that thinks it knows what I want to do. Habari is simple and just works. In short I love it.


Now that I have played with it for a month or so on my local sever I am now ready to put it on my website. When I uploaded a working copy to my webhost it does not work. It now tells me


Habari needs PHP 5.4 or higher to run. You are currently running PHP 5.2.14.


I am on an older shared host and there is zero chance of them upgrading, so I need to work around it if possible.


Is there an older version of Habari that I can use that will work with php 5.2? Or better yet is there an easy way to localize which things require php 5.4 or higher and to edit/remove them?



Thanks,

Brandon



Bryce Campbell

unread,
Jan 11, 2016, 3:34:08 PM1/11/16
to habar...@googlegroups.com

Try to find versions 0.6 or 0.7, but as far as I know the Habari teams prefers to use a supported version of PHP, and mostly newer stuff.

Have you looked into using a different host or hosting it yourself? A page of hosts where Habari has been tested is available on the net somewhere.

--
--
To post to this group, send email to habar...@googlegroups.com
To unsubscribe from this group, send email to habari-dev-...@googlegroups.com
For more options, visit this group at http://groups.google.com/group/habari-dev
---
You received this message because you are subscribed to the Google Groups "habari-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to habari-dev+...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Chris J. Davis

unread,
Jan 11, 2016, 5:48:32 PM1/11/16
to habar...@googlegroups.com
I host all of my Habari sites at digital ocean and it really can't be beat for the price and specs. 

Just my 2 cents in the ring. And welcome to the community! I know we have been silent but it isn't for a lack of love for the project. 

Sent from my iPhone
Reply all
Reply to author
Forward
0 new messages