gwt-dev 2.0.3

105 views
Skip to first unread message

FD

unread,
Mar 16, 2010, 12:57:16 PM3/16/10
to gwt-maven
Hello,

How can I have maven find gwt-dev-2.0.x-windows.jar? It is not on any
repository :-(
Where caa I find it and where should I put it?

Cheers,

F.

Jesse Farinacci

unread,
Mar 16, 2010, 1:48:38 PM3/16/10
to gwt-...@googlegroups.com
You're using the wrong plugin. Try
http://mojo.codehaus.org/gwt-maven-plugin/ instead.

-Jesse

> --
> You received this message because you are subscribed to the Google Groups "gwt-maven" group.
> To post to this group, send email to gwt-...@googlegroups.com.
> To unsubscribe from this group, send email to gwt-maven+...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/gwt-maven?hl=en.
>
>

--
There are 10 types of people in this world, those
that can read binary and those that can not.

Aff

unread,
Apr 7, 2010, 8:11:05 AM4/7/10
to gwt-maven
Excuse me but, does the gwt maven plugin from com.totsp.gwt is wrong
for GWT 2.0.3 ?

How can we know what is better between com.totsp.gwt and mojo ? I'm
new on GWT and I don't understand the difference.

Thanks.

Jesse Farinacci

unread,
Apr 7, 2010, 8:41:11 AM4/7/10
to gwt-...@googlegroups.com
Antoine,

If you had bothered to even spend 30 seconds investigating this
instead of begging someone else for information on this subject you
would have found:

http://code.google.com/p/gwt-maven/

NOTE/UPDATE: This project is deprecated/discontinued. New users should
consider looking at the Codehaus gwt-maven-plugin
(mojo.codehaus.org/gwt-maven-plugin/). The codehaus plugin merged in
the code from this plugin (maven-googlewebtoolkit2-plugin) at one
point and supports most of the same goals (and should be up to date).
Fore more information see the mailing lists and various threads on the
status and difference between the projects:
http://groups.google.com/group/gwt-maven/browse_thread/thread/6ff5102700e6de3c.

-Jesse

ka1n

unread,
May 27, 2010, 12:14:30 PM5/27/10
to gwt-maven
I'm using the Codehaus plugin and still having a problem.

It states: The gwt-maven-plugin will automagically resolve the
required dependency based on your declared gwt-user dependency.

Well, I'm trying to use gwt 2.0.3 and I'm pretty sure this plugin
doesn't work with it. It fails miserably to automagically find my gwt-
dev.jar. When I manually install it to my local maven repo it then
complains about a windows-libs library, which from what I can tell is
not part of gwt 2+.

Forgive me if I missed it, but I don't see a word anywhere on the
plugin page about which versions of gwt are supported.

- Paul

On Apr 7, 8:41 am, Jesse Farinacci <jie...@gmail.com> wrote:
> Antoine,
>
> If you had bothered to even spend 30 seconds investigating this
> instead of begging someone else for information on this subject you
> would have found:
>
> http://code.google.com/p/gwt-maven/
>
> NOTE/UPDATE: This project is deprecated/discontinued. New users should
> consider looking at the Codehaus gwt-maven-plugin
> (mojo.codehaus.org/gwt-maven-plugin/). The codehaus plugin merged in
> the code from this plugin (maven-googlewebtoolkit2-plugin) at one
> point and supports most of the same goals (and should be up to date).
> Fore more information see the mailing lists and various threads on the

> status and difference between the projects:http://groups.google.com/group/gwt-maven/browse_thread/thread/6ff5102....

Shahzeb Khan

unread,
Jul 21, 2010, 8:16:21 PM7/21/10
to gwt-maven
It is a growing epidemic in Java community that people get rude while
replying just as it is a growing epidemic that people only rely on
Google or internet and do not try to solve the issues themselves
first.

Any way I am trying to be neither at the moment .

If you still have not solved the problem then post your pom here . I
have been using 2.0.3 ever since it came out (almost) and have had no
issues .

It could be an issue with your environment only . Does it work with
earlier versions of GWT 2.
Reply all
Reply to author
Forward
0 new messages