Display issues after updating to High Sierra

45 views
Skip to first unread message

Zachary Joyce

unread,
Dec 18, 2017, 11:45:48 AM12/18/17
to Google Web Designer beta

Ever since I updated my Mac to High Sierra,  have run into a display issue with GWD.  provided picture is what happens when I try to publish locally for example.  This doesn't seem to be specific to any file.  GWD is up to date.  I followed instructions in a similar question and turned off GPU rendering, but the issue still remains.

San Khong

unread,
Dec 19, 2017, 2:02:09 PM12/19/17
to Google Web Designer beta
Hi Zachary,

I'm sorry you are running into this issue. We have not yet been able to reproduce it on a High Sierra, however, we were only able to try it on one machine so far.

Can you please try the following

1. Completely remove Google Web Designer from your system by removing the app and running this command in Terminal to remove other files

rm -rf ~/Library/Application\ Support/Google/Web\ Designer ~/Library/Preferences/com.google.WebDesigner.plist 


2. Reboot your machine.

3. Install Google Web Designer again.

4. Launch it and quit.

5. Run the following command in Terminal to disable gpu rendering:

defaults write com.google.WebDesigner.plist disable-gpu-rendering -bool true


6. Launch Google Web Designer. 

7. Open a file, select Edit > Preferences > Advanced and turn on Verbose logging.

8. When you run into the issue again, quit Google Web Designer, then send us the log files in /Users/<username>/Library/Application Support/Google/Web Designer/logs

Thanks,
San
Google Web Designer team

Zachary Joyce

unread,
Jan 12, 2018, 12:27:41 PM1/12/18
to Google Web Designer beta
Hi San!

Thanks for getting back to me, unfortunately the problem is still occurring, i've attached the logs as asked. 

Cheers,

Zack
browser.log
renderer.log

peter.h...@baselgovernance.org

unread,
Jan 15, 2018, 4:28:09 PM1/15/18
to Google Web Designer beta
Dear Zack,

I had the same problem on my Mac after updating to High Sierra. It was resolved after I completely removed and re-installed GWD:
1) Remove the Application
2) Remove ~/Library/Preferences/com.google.WebDesigner.plist
3) Restart the Mac
4) Download and re-install GWD

Regards,

Peter

Reply all
Reply to author
Forward
0 new messages