Keep getting stuck in either Design / Code view

85 views
Skip to first unread message

to...@tshaped.co.uk

unread,
May 31, 2016, 12:39:08 PM5/31/16
to Google Web Designer beta
Using GWD on iMac, I repeatedly get stuck in either Design or Code view, and I am unable to switch between the two. Both buttons become highlighted when I try to switch but nothing happens.

This happens constantly. The only way to regain control is to close and re-open the file I'm working on. This means every 1-2 minutes, so the app is borderline unusable for me.

Does anyone know how to fix this?

Google Web Designer beta

unread,
May 31, 2016, 2:57:30 PM5/31/16
to Google Web Designer beta
Hi Toby,

Are you using Mac OS X 10.7 or higher on your iMac?  Does this happen while you are editing a specific element?
Does shortcut key (Cmd + Shift + C) to switch between Design/Code view work for you when it happens?
Please provide us the detailed steps to reproduce the issue so that we can debug.

Thanks,
Rika
(GWD team)

to...@tshaped.co.uk

unread,
Jun 1, 2016, 5:36:42 AM6/1/16
to Google Web Designer beta
Hi Rika, thanks for the reply.

I am using OS X 10.11.4.

It can happen at any time when switching between design / code view after I have edited any type of element in either view. With elements currently selected or without makes no difference.

The only possibly "unusual" thing about my ad is that I'm loading a custom font in via a linked (remote) stylesheet on webtype.com

The keyboard shortcut does not work for me when I get stuck in either view.

Google Web Designer beta

unread,
Jun 1, 2016, 3:20:20 PM6/1/16
to Google Web Designer beta
Hi Toby,

Can you try removing the web font link and see if you still see the issue?

Thanks,
Rika
(GWD team)

to...@tshaped.co.uk

unread,
Jun 7, 2016, 7:02:05 AM6/7/16
to Google Web Designer beta
Hi Rika, that has solved the problem. However we will need to use a remote web font link for many projects in the future.

Do you think it could be something the development team can look at fixing?

Thanks!

three....@gmail.com

unread,
Jun 7, 2016, 10:47:38 AM6/7/16
to Google Web Designer beta
i'm having the same problem. mac - 10.11.2. mac book pro. i don't have any custom font links. i'm linking to the greensock hosted links on double click.

it can happen that one file still works fine and one does not, while they are both open.

Google Web Designer beta

unread,
Jun 7, 2016, 12:05:35 PM6/7/16
to Google Web Designer beta
Hi Toby,

We had a similar issue with switching document tabs and that has been fixed internally.  
If possible, can you send us your creative (before publishing) to gwd-s...@google.com?
In this way, we can debug your issue.

Thanks,
Rika
(GWD team)

Google Web Designer beta

unread,
Jun 7, 2016, 12:10:07 PM6/7/16
to Google Web Designer beta
Hi Charles,

Can you send your creative (before publishing) to gwd-s...@google.com as well?

Thanks,
Rika
(GWD team)

Google Web Designer beta

unread,
Jun 7, 2016, 8:38:22 PM6/7/16
to Google Web Designer beta
Hi Charles,

Thanks for sending your file.  We couldn't reproduce your issue on our end.
Can you please clear the application cache and try again?  Here is the cache location on your Mac:

/Users/<username>/Library/Application Support/Google/Web Designer/data/cache

If you continue to see the issue, please let us know the detailed steps.  Taking video may be helpful.
Also, letting us know what you've done right before you started seeing the problem will be helpful.

Regards,
Rika
(GWD team)




Reply all
Reply to author
Forward
0 new messages