Cross-Browser Rendering Not Working Properly

546 views
Skip to first unread message

dartmoti...@gmail.com

unread,
Mar 11, 2015, 5:59:11 PM3/11/15
to gwd...@googlegroups.com, carina....@digitas.com
Hi GWD team,
I finally decided to build 3 banner ads out with GWD of which 2 appear to have issues. Unfortunately timing is sensitive so I would hope to hear from someone back as soon as possible.

My issues:

Studio creative preview for Version 1
Chrome 41.0.2272.76: Animation plays fine.
Firefox 36.0.1: Animation plays fine.
Safari 7.1.3: In the end frame, the card appears to be cut off

Studio creative preview for Version 2
Chrome 41.0.2272.76: Animation plays fine.
Firefox 36.0.1: Card flipping animation appears to loop which is not the same with how it is animated in Chrome
Safari 7.1.3: Animation plays until the end however the card animation is not smooth and it is blurred.

Moreover I'm also able to see the issues above happen when I test both creatives across browsers locally using the preview option inside the GWD.

Is there a way that I can privately share the files in question with one of you?
Thanks a bunch!

Mariko Ogawa

unread,
Mar 11, 2015, 8:12:05 PM3/11/15
to gwd...@googlegroups.com, carina....@digitas.com
Hello,

Do you have 3d translation(or rotation) in your animation?

The issue you see in Safari might be related to the following thread. Please take a look at this.
https://groups.google.com/forum/#!searchin/gwdbeta/-1$20z/gwdbeta/f_233_wAjIY/JcLsbqJb3OQJ

And also we understand that Firefox renders 3d rotation differently from other browsers.

Thanks,
Mariko (GWD team)

Mariko Ogawa

unread,
Mar 12, 2015, 1:56:13 PM3/12/15
to gwd...@googlegroups.com, carina....@digitas.com
Hi, I might have a workaround for your Safari issue where it shows cut-off.

Please apply negative Z values (such as -10px, or -20px, whatever the value works) to an element that is placed right below the card 3d animation.
You can do this in Properties inspector>3D position and view>Z(px) the top Z input box.

Firefox 36.0.1: Card flipping animation appears to loop which is not the same with how it is animated in Chrome 
This is probably related to this bug in Firefox: 

Safari 7.1.3: Animation plays until the end however the card animation is not smooth and it is blurred. 
It is hard to tell what's going on this one, but it is probably also related to Safari's rendering issue with 3d matrix.
Reply all
Reply to author
Forward
0 new messages