1.4.1 Unusably slow and unresponsive on OSX 10.9.3

455 views
Skip to first unread message

jro...@gmail.com

unread,
Sep 17, 2015, 2:34:23 AM9/17/15
to Google Web Designer beta
I'm trying to use GWD 1.4.1 but the application is unusably slow.

There is a lag time with the cursor where the "x" cursor trails the arrow cursor by a second or more.
(Not to mention that the "x" cursor and the arrow cursor probably shouldn't be visible at the same time).

The application is also extremely unresponsive. Clicks on elements can take more than a second to register -- and often don't register at all.

I'm using OSX 10.9.3 with 4GB RAM

Jaz

unread,
Sep 17, 2015, 11:56:29 AM9/17/15
to Google Web Designer beta
Hi,

Can you please clear the Google Web Designer application cache:

Application cache locations:
Windows: 
\Users\<username> \AppData\Local\Google\Google Web Designer\data\cache

MAC:
/Users/<username>
/Library/Application Support/Google/Web Designer/data/cache


Please let us know if this resolves the issue!

thx
jaz
Program Manager, GWD

sch...@gmail.com

unread,
Oct 5, 2015, 4:47:20 AM10/5/15
to Google Web Designer beta
I HAVE THE SAME PROBLEM.
OSX 10.7.5 16BG RAM
Graphics NVIDIA GeForce 7300 GT 256 MB

Application is extremely slow and unresponsive. It is unusable at this point.

sch...@gmail.com

unread,
Oct 5, 2015, 4:56:24 AM10/5/15
to Google Web Designer beta
No, clearing cache does not help.

Not sure what exactly did you mean by "clearing", what I did is deleted all the files in the directory mentioned. No changes.

San Khong

unread,
Oct 8, 2015, 3:59:49 PM10/8/15
to Google Web Designer beta
Please try disconnecting from the internet to force Google Web Designer to run in offline mode so we can rule out the possibility with network connection issues.

Please let me know if things improve or you still see the same performance issues.

Thanks,
San
GWD Team

sch...@gmail.com

unread,
Oct 9, 2015, 9:44:50 AM10/9/15
to Google Web Designer beta
nope. no change.

lest...@gmail.com

unread,
Oct 9, 2015, 10:55:41 AM10/9/15
to Google Web Designer beta
I can confirm, this is happening on my Macbook Pro too, OS X Yosemite. It only happens in design mode, in coding mode it's fine. It slows down the whole computer, it isn't confined to GWD.

Ty Nowicki

unread,
Nov 12, 2015, 5:46:05 PM11/12/15
to Google Web Designer beta
I'm running 10.10.5 and it's doing the same thing. Extremely slow, lagging, and I have to keep clicking in and out of the app to even make it responsive.

mr.d...@gmail.com

unread,
Nov 14, 2015, 9:14:47 AM11/14/15
to Google Web Designer beta
I am having the same issue. Extremely unresponsive on my mac book pro thats running Yosemite with 4G ram. I am nesting divs and it takes about 15 clicks to get back to the outer div if ever. I have been having to quit the application and reopen to make it respond again. I had to switch back to Adobe Edge to finish my work. It is a shame, because this application has so much promise, but I do not think it is ready yet.

sch...@gmail.com

unread,
Nov 16, 2015, 3:04:30 AM11/16/15
to Google Web Designer beta
That's why i saif fck-this and learned GreenSock.com animation by hand. Took me a week to do. If one can write front-end HTML/CSS it wont be a problem.

fro...@conference-interpreter.com

unread,
May 25, 2017, 8:07:07 AM5/25/17
to Google Web Designer beta
As a flash web designer, which doesn't work on iPads and iPhones,
I thought GWD would be a solution to my animations. Started off ok but as the animations got more complicated so did the interface response time. It is now unusable waiting 15 minutes for a save and longer to publish. Tried all the above but no better. Have to resort to uninstalling and reinstalling just to move forward a bit.

San Khong

unread,
May 25, 2017, 12:57:33 PM5/25/17
to Google Web Designer beta
Hi froggy, 

Can you please let me know your system configuration? OS, RAM, processor, etc.

Please also check what version of GWD you are running.

Thanks,
San
Google Web Designer team

fro...@conference-interpreter.com

unread,
May 26, 2017, 1:06:06 PM5/26/17
to Google Web Designer beta
Hi, I am using Windows 10 Pro, Intel(R) core (TM) 13-4150 CPU 350Gz, 64 Bit, 8GB RAM, GDW version 1.8.2.0524

The systems has completely stopped working. I also installed it on another PC which had been restored to factory settings and it did not work on this eithe

Froggy

fro...@conference-interpreter.com

unread,
May 26, 2017, 1:15:16 PM5/26/17
to Google Web Designer beta
Other problems I've found, my site is in French and English. When the French is published, all letters with accents are changed to a miss match of strange characters. Also, tried everything to get the tap-to-call to work, it says it's sailing but no phone call is made. You can see my site so far on www.riviera-web-design.net/index.html

San Khong

unread,
May 26, 2017, 6:53:06 PM5/26/17
to Google Web Designer beta
Froggy, if you use 
<head>
  <meta charset="utf-8">
  <title>
Then it should work. Please move <meta charset="utf-8"> which is added by GWD to the top after head, then try remove other charset you have in the file, and copy and paste the French characters again, save the file and reopen, and the French characters should display properly again.

For the taptocall issue, there is a known issue that it's not working on Safari on iOS and we will take a look at it. What device did you see the problem in?

fro...@conference-interpreter.com

unread,
May 27, 2017, 3:07:01 AM5/27/17
to Google Web Designer beta
Hi, I was using safari to call so I'll try something else, also add the character set.
Probl em is GWD has now ground to a halt so I cannot even open a page?

hansj....@gmail.com

unread,
Mar 16, 2018, 5:35:59 AM3/16/18
to Google Web Designer beta
Hi, I use OSX 10.9.5 8GB memory.
I try to work 1st time with google web designer. Extremely slow responding or not responding at all as mentioned by other users. I also can't find any cache as mentioned for mac.
Furthermore, templates are not available, just nothing happen when I open directories on search screen.
Thanks for quick respons.
Regards, Hans

hansj....@gmail.com

unread,
Mar 16, 2018, 5:50:40 AM3/16/18
to Google Web Designer beta
Moreover, I even can't set a location for the banners, html etc. There occur a red strip. Ok button is yellow, nothing happens further....

San Khong

unread,
Mar 16, 2018, 12:04:08 PM3/16/18
to Google Web Designer beta
hansj,

We tested Google Web Designer on 10.9.5 and it was fine for us. Can you please let us know if your Mac is set up with any special configuration such as network drive, Time Machine, etc.

One thing you can help us is to get us the log file so we can see why the templates are not available. 

1. Launch Google Web Designer.
2. Select Edit > Preferences > Advanced. 
3. Check the verbose logging checkbox. 
4. File > New from templates...
5. Quit Google Web Designer.
6. Browse to the following directory and attach the browser.log to this post:
  • Mac: /Users/<username>/Library/Application Support/Google/Web Designer/logs 
Please also take a screenshot of the New file dialog where you cannot create a new file so we can check out the file path.

kurtin...@gmail.com

unread,
Jun 24, 2018, 10:41:29 PM6/24/18
to Google Web Designer beta
Hi,

I'm using GWD 4.0.0.0.615

OSX 10.11.6 16gb

I am having the same lagging issue, very un-useable.

San Khong

unread,
Jun 26, 2018, 3:03:05 PM6/26/18
to Google Web Designer beta
Hi kurtingwersen,

We just installed a fresh image of 10.11.6 on a MacBook Pro and could not reproduce the performance issue. Please help us reproduce this by letting us know your Mac settings. Do you have Time Machine on, etc., anything else you can think of that was set on your Mac?

San Khong

unread,
Jul 2, 2018, 6:20:03 PM7/2/18
to gwd...@googlegroups.com
To solve the issue, please do the following:

Quit Google Web Designer and follow this instruction before relaunching:
  • Mac: Add a Boolean row to ~/Library/Preferences/com.google.WebDesigner.plist with the name disable-gpu-rendering and a value of YES, or run defaults write com.google.WebDesigner.plist disable-gpu-rendering -bool true in Terminal.
Reply all
Reply to author
Forward
0 new messages