Duplicate class com.google.common.util.concurrent.ListenableFuture found in modules guava-16.0.1.jar (com.google.guava:guava:16.0.1) and listenablefuture-1.0.jar (com.google.guava:listenablefuture:1.0)

34 views
Skip to first unread message

Hardik Jigar

unread,
Nov 25, 2020, 1:06:28 AM11/25/20
to guava-discuss
Duplicate class com.google.common.util.concurrent.ListenableFuture found in modules guava-16.0.1.jar (com.google.guava:guava:16.0.1) and listenablefuture-1.0.jar (com.google.guava:listenablefuture:1.0)

David P. Baker

unread,
Nov 30, 2020, 9:22:53 AM11/30/20
to Hardik Jigar, guava-discuss
Guava 16.0.1 is from 2014; that should not be in your dependency graph. The latest version is 30.0-jre or 30.0-android, which depends on version 9999.0-empty-to-avoid-conflict-with-guava of listenablefuture, which is empty. See https://github.com/google/guava/blob/master/futures/listenablefuture9999/pom.xml#L14 for more information.

On Wed, Nov 25, 2020 at 1:06 AM Hardik Jigar <hitea...@gmail.com> wrote:
Duplicate class com.google.common.util.concurrent.ListenableFuture found in modules guava-16.0.1.jar (com.google.guava:guava:16.0.1) and listenablefuture-1.0.jar (com.google.guava:listenablefuture:1.0)

--
guava-...@googlegroups.com
Project site: https://github.com/google/guava
This group: http://groups.google.com/group/guava-discuss
 
This list is for general discussion.
To report an issue: https://github.com/google/guava/issues/new
To get help: http://stackoverflow.com/questions/ask?tags=guava
---
You received this message because you are subscribed to the Google Groups "guava-discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to guava-discus...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/guava-discuss/c8d19008-81fe-4ba5-ab1e-d64bf8ae921bn%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages