On 9 May 2012 11:14, spirit <
arekmic...@gmail.com> wrote:
> Hi, I have a question. In GM builtin function like GM_getValue,
> GM_setValue etc. have use uppercase letters on begin (GM). Like we
> know, in JavaScript good custom is to use a capital letter at the
> start of the constructors function.
>
Its a legacy naming scheme, If greasemonkey where invented today, It
probably would use something like greasemonkey.store.setValue() or
gm.setValue(), like you have console.log() for firebug.
Javascript is not Java, anyway, the customs are hilariously
fragmented. GM_getValue may look like a constructor to a Java
programer, but to me, that I have a C background, looks like a ugly
macro :-/
--
--
ℱin del ℳensaje.