This editor won't do

39 views
Skip to first unread message

gnblizz

unread,
Jan 13, 2018, 9:10:42 AM1/13/18
to greasemonkey-dev
In case You didn't figured already, this is about the removed external editor option in GM4.1
An alternate topic could be: Why invent bicycles again, if specialized native ones are completely fine or A cobbler should stick to his last.

1. Missing UI

My first impression was: 'something is missing'. I was looking for a 'safe' button. No auto safe nor OnClose handler either...
The educated guess CTRL+S brought up the standard save dialog of the browser. (The focus was still at the scroll bar.)
I strongly recommend to add at least a hint at first run that the user has to press CTRL+S while the curser is in the edited user script.

2. Missing clipboard support.

Copy text selection with middle mouse button works only occasionally. This in the Linux world well known method is a comfortable way of copying and it is independent of the other clipboard you use with the keyboard. The results with Firefox are unpredictable. This has never worked with Firefox and is very unlikely to be fixed ever.

3. Missing standard drag and drop implementation.


As in all other CodeMirror based applications, drag and drop is only partially implemented. It gives wrong feedback at keyboard events and copies only when you pressed CTRL before the left mouse button.
I told Majin long time ago about this but he couldn't see a necessity to fix this. He suggested to learn to press CTRL early instead. Estimated time of fix: never.

4. Missing a highlight feature.

The editor I use for programming highlights all occurrences of the currently selected word. This is quite useful for a quick overview, where a selected variable is also used. I'd miss that feature.


Now I had enough. I opened the old editor again before I even tested the search and replace regex funtionality, the go to line short cut CTRL+G and so on and on. After some editing I did the following key sequence: CTRL+A CTRL+C ALT+TAB CTRL+A CTRL+V CTRL+S. With this method I could do compatibility tests for Tampermonkey in chromium, but of course this is absolutely not suitable for debugging user scripts.

I doubt Mozilla developers will relent and allow file access again (Although, they did so for adobe with NTAPI), so I wonder now whether I should change to Pale moon or close my GreasyFork account before ratings begin to drop.

PS: As I first installed Tampermonkey there was an option to grant access to the add-on sub folder, which would suffice. However, this never worked on my system.

Reply all
Reply to author
Forward
0 new messages