37 views
Skip to first unread message

Ying Jin

unread,
Jun 7, 2021, 2:57:19 PMJun 7
to google-we...@googlegroups.com
Hello,

We have an application can not compile using GWT-2.9 with JDK 11 after upgraded from GWT 2.5 and JDK 8.

It would be great if you can help shed some light on this. Please see below for the error:

Compiling module edu.vanderbilt.mc.aries.ARIES
[ERROR] Unexpected internal compiler error
java.lang.NoSuchFieldError: warningThreshold
at com.google.gwt.dev.javac.JdtCompiler$1.<init>(JdtCompiler.java:634)
at com.google.gwt.dev.javac.JdtCompiler.getStandardCompilerOptions(JdtCompiler.java:632)
at com.google.gwt.dev.javac.JdtCompiler.getCompilerOptions(JdtCompiler.java:664)
at com.google.gwt.dev.javac.JdtCompiler.doCompile(JdtCompiler.java:1015)
at com.google.gwt.dev.javac.CompilationStateBuilder$CompileMoreLater.compile(CompilationStateBuilder.java:322)
at com.google.gwt.dev.javac.CompilationStateBuilder.doBuildFrom(CompilationStateBuilder.java:532)
at com.google.gwt.dev.javac.CompilationStateBuilder.buildFrom(CompilationStateBuilder.java:464)
at com.google.gwt.dev.cfg.ModuleDef.getCompilationState(ModuleDef.java:423)
at com.google.gwt.dev.Precompile.precompile(Precompile.java:210)
at com.google.gwt.dev.Precompile.precompile(Precompile.java:190)
at com.google.gwt.dev.Precompile.precompile(Precompile.java:131)
at com.google.gwt.dev.Compiler.compile(Compiler.java:192)
at com.google.gwt.dev.Compiler.compile(Compiler.java:143)
at com.google.gwt.dev.Compiler.compile(Compiler.java:132)
at com.google.gwt.dev.Compiler$1.run(Compiler.java:110)
at com.google.gwt.dev.CompileTaskRunner.doRun(CompileTaskRunner.java:55)
at com.google.gwt.dev.CompileTaskRunner.runWithAppropriateLogger(CompileTaskRunner.java:50)
at com.google.gwt.dev.Compiler.main(Compiler.java:113)

Your help is greatly appreiciated!
Jenny

Thomas Broyer

unread,
Jun 8, 2021, 1:19:31 PMJun 8
to GWT Users
At this line in JdtCompiler, the warningThredshold field is part of a JDT class, so double check your dependencies, your probably have an incompatible JDT/ECJ dependency in your classpath.
Reply all
Reply to author
Forward
0 new messages