GWT Developer Plugin for Firefox 8

7215 views
Skip to first unread message

Alan Leung

unread,
Nov 9, 2011, 5:07:31 AM11/9/11
to google-we...@googlegroups.com
Hi all:

I just finished building / testing the FF8 dev mode plugin for Linux 32 bit (http://www.sendspace.com/file/h8wgmn)

More to come tomorrow.

Again, if you are using FF8 already. I'd greatly appreciate if you give that a try and let me know when you see anything weird.

-Alan

Thad

unread,
Nov 9, 2011, 10:57:33 AM11/9/11
to Google Web Toolkit
Thanks, Alan. After uninstalling the FF7 plug-in, I restarted FF8 and
loaded this. My first attempt to use it was successful. I'll keep you
posted.

For your records, I'm running FF on OpenSuSE 11.4, 32-bit with GWT 2.3
(gonna run 2.4 as soon as I get permission to drop support from some
old Mac servers).

BTW, I was attempting to do the same thing, but was unable to build
Firefox so I'd have the libraries and headers necessary for plugin-
sdks/gecko-sdks/gecko-8.0.0. I cloned mozilla-central overnight. This
morning I created .mozconfig and ran make -f client.mk but quickly got
the error ".../client.mk:282: *** Could not find autoconf 2.13.
Stop." This I don't understand: Why would it require 2.13 exactly? (I
have 2.68 in the path.) I was gonna play with the AUTOCONF setting in
client.mk when I saw your announcement.

Thanks again.

David Guo

unread,
Nov 9, 2011, 8:31:49 PM11/9/11
to google-we...@googlegroups.com
I'll try it in Win7 64 bit to see if it works or not.
If not,maybe i CAN rebuild it on my own.

Alan Leung

unread,
Nov 10, 2011, 5:11:33 AM11/10/11
to google-we...@googlegroups.com
Alright I have built and tested it for all platforms

Have fun!

http://www.fileswap.com/dl/1OVPVHwWEp/gwt-dev-plugin.xpi.html

-Alan

On Wed, Nov 9, 2011 at 5:31 PM, David Guo <angel...@gmail.com> wrote:
I'll try it in Win7 64 bit to see if it works or not.
If not,maybe i CAN rebuild it on my own.

--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.
To view this discussion on the web visit https://groups.google.com/d/msg/google-web-toolkit/-/Yp5Y2pWEV2gJ.

To post to this group, send email to google-we...@googlegroups.com.
To unsubscribe from this group, send email to google-web-tool...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/google-web-toolkit?hl=en.

Thomas Klöber

unread,
Nov 10, 2011, 5:48:47 AM11/10/11
to google-we...@googlegroups.com
Am 10.11.2011 11:11, schrieb Alan Leung:
> Alright I have built and tested it for all platforms
>
> Have fun!
>
> http://www.fileswap.com/dl/1OVPVHwWEp/gwt-dev-plugin.xpi.html
brilliant! Thanx Alan for the quick job. I was already worried I had to
stick with the "old" FF version for weeks...

Thomas

PS: anyone knows what's the matter with Mozilla these days that they
keep banging together new "major" releases of FF and TB? Is it a QA
problem or do they just want to push up their version numbers ;)

--
Intelligent Communication Software Vertriebs GmbH
Firmensitz: Kistlerhof Str. 111, 81379 M�nchen
Registergericht: Amtsgericht M�nchen, HRB 88283
Gesch�ftsf�hrer: Albert Fuss

Alan Chaney

unread,
Nov 10, 2011, 10:50:51 AM11/10/11
to google-we...@googlegroups.com
On 11/10/2011 2:11 AM, Alan Leung wrote:
Alright I have built and tested it for all platforms

Have fun!

http://www.fileswap.com/dl/1OVPVHwWEp/gwt-dev-plugin.xpi.html

-Alan
Thanks, Alan! Great work!


Seems to work on FF8 Win 7 x64.

(also) Alan

Samyem Tuladhar

unread,
Nov 10, 2011, 10:52:23 AM11/10/11
to google-we...@googlegroups.com
Thanks. Worked for me as well. Wonder if the GWT official team would be able to pick this up and offer through the official channel. 

Luca Morettoni

unread,
Nov 10, 2011, 10:56:14 AM11/10/11
to google-we...@googlegroups.com
On Thu, Nov 10, 2011 at 4:52 PM, Samyem Tuladhar <sam...@gmail.com> wrote:
> Thanks. Worked for me as well. Wonder if the GWT official team would be able
> to pick this up and offer through the official channel.

and it's incredible that the chrome plugin is tremendous slower than the ff one!

--
Luca Morettoni <luca(AT)morettoni.net> | http://www.morettoni.net
gtalk/msn: luca(AT)morettoni.net | http://twitter.com/morettoni
jugUmbria founder: https://jugUmbria.dev.java.net/ | skype: luca.morettoni
Member of Python User Group Perugia: http://www.pypg.org/

Samyem Tuladhar

unread,
Nov 10, 2011, 11:00:15 AM11/10/11
to google-we...@googlegroups.com
The gwt official plugin is still stuck with FF6 - already 2 version behind. 

Igor Lysak

unread,
Nov 10, 2011, 5:52:39 AM11/10/11
to Google Web Toolkit
Thanks a lot, Alan! Good work!

Juan Pablo Gardella

unread,
Nov 10, 2011, 12:38:36 PM11/10/11
to google-we...@googlegroups.com
Awesome Alan, is very fast!!!

2011/11/10 Igor Lysak <lysak...@gmail.com>

Thomas Broyer

unread,
Nov 10, 2011, 2:50:41 PM11/10/11
to google-we...@googlegroups.com
Alan *is* from the "GWT official team"!

Thomas Broyer

unread,
Nov 10, 2011, 2:52:03 PM11/10/11
to google-we...@googlegroups.com
It's been officially updated to FF7 yesterday (the XPI was downlodable for a long time already on the SVN): http://code.google.com/p/google-web-toolkit/source/detail?r=10735

Michael Vogt

unread,
Nov 10, 2011, 4:59:26 PM11/10/11
to google-we...@googlegroups.com
Hello Alan.

> Alright I have built and tested it for all platforms
> Have fun!
>

Thank you for the update. Worked for me without problem today.

Ubuntu 11.10 32-bit with GWT 2.4


Greetings,
Michael

Alan Leung

unread,
Nov 10, 2011, 5:27:02 PM11/10/11
to google-we...@googlegroups.com
Right. I keep a very close watch on the FF release schedule. The latest and greatest is usually in SVN quickly if you are feeling adventurous.

I am slightly hesitant to push it out to the official page because I don't want to break EVERY GWT user with a bad build. If you are downloading from the SVN, I assume you have no problem uninstalling a bad version if it didn't work for you.

-Alan


On Thu, Nov 10, 2011 at 11:52 AM, Thomas Broyer <t.br...@gmail.com> wrote:
It's been officially updated to FF7 yesterday (the XPI was downlodable for a long time already on the SVN): http://code.google.com/p/google-web-toolkit/source/detail?r=10735

--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.

bryn ryans

unread,
Nov 10, 2011, 5:44:33 PM11/10/11
to Google Web Toolkit

Any particular reason why the FF8 plugin has been uploaded www.fileswap.com

rather than google-web-toolkit SVN (http://google-web-
toolkit.googlecode.com/svn/trunk/plugins/xpcom/prebuilt/)?

Thanks.

David Guo

unread,
Nov 10, 2011, 8:32:56 PM11/10/11
to google-we...@googlegroups.com
Well done Alan,great work.
Work well on FF8 in Win7 64 bit.

csillag

unread,
Nov 11, 2011, 5:55:30 AM11/11/11
to Google Web Toolkit
When running inside Iceweasel 8.0, the plugin in installed correctly,
but dev mode does not work.

Kristof

csillag

unread,
Nov 11, 2011, 7:03:13 AM11/11/11
to Google Web Toolkit
Sorry, false alarm.

I installed the wrong version (which contained only the 32 bit
version) on a 64bit system.
The later version works all right.

Thank you, this way much faster than the previous rounds.

James Wendel

unread,
Nov 12, 2011, 9:51:29 PM11/12/11
to Google Web Toolkit
Agreed. It would be nice to see this uploaded to SVN.

Alan Leung

unread,
Nov 14, 2011, 5:12:35 AM11/14/11
to google-we...@googlegroups.com
I started a code review already.

Levi Van Zele

unread,
Nov 18, 2011, 4:23:18 AM11/18/11
to google-we...@googlegroups.com
Thanks a lot! Works on Ubuntu amd64 as well.

vlatkoB

unread,
Nov 22, 2011, 5:33:34 AM11/22/11
to google-we...@googlegroups.com
Works on Ubuntu 64, FF 8 64. Thanks!

SurfMan

unread,
Nov 22, 2011, 6:21:03 AM11/22/11
to google-we...@googlegroups.com
I can confirm this plugin works on Fedora 15 64 bit, on Firefox 8. I am using it in conjunction with IntelliJ's debugger. I can now fire up the server, start the debugger, then use this plugin to connect. Even hot-swap of compiled code works :)

Thanks for your efforts!!


SamReciter

unread,
Nov 24, 2011, 8:44:27 AM11/24/11
to google-we...@googlegroups.com
Very well, Alan. Works great for me (also Win7 64bit). Thanks a lot. Saves my day.

David Vree

unread,
Nov 25, 2011, 1:13:29 AM11/25/11
to google-we...@googlegroups.com
This is huge as my Ubuntu workstations are all at Firefox 8...thanks a ton for posting this.

rakesh wagh

unread,
Nov 28, 2011, 1:15:40 PM11/28/11
to google-we...@googlegroups.com
unfortunately fileswap.com is blocked here. Is there an alternate location from where I can download? I am looking for firefox plugin on 64bit/win7. Thanks, greatly appreciated! 

Rakesh Wagh 

Dimitrijević Ivan

unread,
Nov 29, 2011, 4:26:39 AM11/29/11
to google-we...@googlegroups.com
When will you put FF8 GWT plugin in SVN repo?

Samyem Tuladhar

unread,
Nov 29, 2011, 9:23:07 AM11/29/11
to google-we...@googlegroups.com
By the time the official GWT firefox plugin supports version 8, Firefox would already have been out on version 15! 

Thomas Broyer

unread,
Nov 29, 2011, 11:22:29 AM11/29/11
to google-we...@googlegroups.com
By the time Firefox will be on version 15, the Dev plugin hopefully won't be needed anymore (google for "gwt super draft mode")

rakesh wagh

unread,
Nov 30, 2011, 8:31:46 PM11/30/11
to google-we...@googlegroups.com
I got the file. works well! good job... keep it up. 

Bruce Grant

unread,
Dec 6, 2011, 2:02:55 PM12/6/11
to Google Web Toolkit
Many thanks Alan - saved me much frustration and re-installs!

Steve

unread,
Dec 8, 2011, 5:05:11 PM12/8/11
to google-we...@googlegroups.com
Hmm, I'm having problems.  Testing with the "Web Application Starter Project" from GPE wizard.  It renders initial screen (and breakpoints work), but when I press the Send button nothing happens (including clickHandler breakpoints).  Works when I use Chrome and IE.  Win 7, GPE 2.4r37.

Steve

Alan Leung

unread,
Dec 9, 2011, 5:31:28 AM12/9/11
to google-we...@googlegroups.com
Do you have more details? This is the exact same set up I use to test it after building it.

-Alan

On Thu, Dec 8, 2011 at 2:05 PM, Steve <steve....@gmail.com> wrote:
Hmm, I'm having problems.  Testing with the "Web Application Starter Project" from GPE wizard.  It renders initial screen (and breakpoints work), but when I press the Send button nothing happens (including clickHandler breakpoints).  Works when I use Chrome and IE.  Win 7, GPE 2.4r37.

Steve

--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.

Steve

unread,
Dec 11, 2011, 9:27:33 AM12/11/11
to google-we...@googlegroups.com
The click handler for the "Send" button never gets called using FF8.  I set a breakpoint in the strawman module in "MyHandler.onClick()" and it gets hit in Chrome but not FF8 with GWT.

I tried both Java 7 and Java 6.

I'm using Eclipse Indigo, GPE 2.4r37, FF 8.0.1.  All *pretty clean installs.  I'll try a clean install tomorrow.

Not sure if related, but the GPE wants to update but every time I try it seems to timeout doing the download.  I've tried this half a dozen times over two weeks.

Steve

Dimitrijević Ivan

unread,
Dec 12, 2011, 4:46:13 AM12/12/11
to google-we...@googlegroups.com
Finally, I saw GWT FF8 plugin in the repo: http://code.google.com/p/google-web-toolkit/source/browse/trunk/plugins/xpcom/prebuilt/gwt-dev-plugin.xpi

I've successfully tested on the MacOS X. No problems found.

tdk

unread,
Dec 13, 2011, 6:54:04 AM12/13/11
to google-we...@googlegroups.com
... and now we have FF 8.0.1 and yet again the plugin is reported as being incompatible.
What on earth is going on?

Jens

unread,
Dec 13, 2011, 6:59:53 AM12/13/11
to google-we...@googlegroups.com
I have FF 8.0.1 (OS X) and the plugin works great (http://www.fileswap.com/dl/1OVPVHwWEp/gwt-dev-plugin.xpi.html)

-- J.

Thomas Klöber

unread,
Dec 13, 2011, 7:09:46 AM12/13/11
to google-we...@googlegroups.com
Am 13.12.2011 12:59, schrieb Jens:
I have FF 8.0.1 (OS X) and the plugin works great (http://www.fileswap.com/dl/1OVPVHwWEp/gwt-dev-plugin.xpi.html)
not for me on Windows Server 2003 R2 SP2. It says its not compatible and refuses to install...
-- 
Intelligent Communication Software Vertriebs GmbH
Firmensitz: Kistlerhof Str. 111, 81379 München
Registergericht: Amtsgericht München, HRB 88283
Geschäftsführer: Albert Fuss

Alan Leung

unread,
Dec 13, 2011, 3:23:53 PM12/13/11
to google-we...@googlegroups.com
Just making sure everyone is getting the right version.


I have verified that it works on Firefox 8.0.1 just now.

-Alan


--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.

Thomas Klöber

unread,
Dec 14, 2011, 2:01:19 AM12/14/11
to google-we...@googlegroups.com
Am 13.12.2011 21:23, schrieb Alan Leung:
> Just making sure everyone is getting the right version.
>
> https://dl.google.com/dl/gwt/plugins/firefox/1.0.10791/gwt-dev-plugin.xpi
>
> I have verified that it works on Firefox 8.0.1 just now.
yep, this work for FF 8.0.1 on Windows 7 x64

--
Intelligent Communication Software Vertriebs GmbH

Firmensitz: Kistlerhof Str. 111, 81379 M�nchen
Registergericht: Amtsgericht M�nchen, HRB 88283
Gesch�ftsf�hrer: Albert Fuss

Steve

unread,
Dec 14, 2011, 7:42:27 PM12/14/11
to google-we...@googlegroups.com
It works!  The problem was some Firefox extension or plugin somehow caused problems.  Once I disabled everything except GWT, it worked.  Thanks Alan!

Steve

Dimitrijević Ivan

unread,
Dec 16, 2011, 4:45:34 AM12/16/11
to google-we...@googlegroups.com, klo...@ics.de
Also verified and tested on Win 7 64bit.
It seams that everything is OK.

Samyem Tuladhar

unread,
Dec 21, 2011, 1:20:41 PM12/21/11
to google-we...@googlegroups.com
Can the plugin be made to work on the current stable release of Firefox 9 as well? Thanks.

Alan Leung

unread,
Dec 21, 2011, 2:42:07 PM12/21/11
to google-we...@googlegroups.com
Not sure. The official xulrunner sdk was not release until today. I am currently testing it.

I'll keep everyone updated.

-Alan

On Wed, Dec 21, 2011 at 10:20 AM, Samyem Tuladhar <sam...@gmail.com> wrote:
Can the plugin be made to work on the current stable release of Firefox 9 as well? Thanks.

--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.

tmy

unread,
Dec 21, 2011, 7:45:06 PM12/21/11
to google-we...@googlegroups.com
Looking forward to the good news, but it is really annoying that the extension is incompatible after firefox upgrades every time, especially today firefox updates much more frequently.
Anyway, thanks so much, Alan! 

Alan Leung

unread,
Dec 22, 2011, 4:32:13 AM12/22/11
to google-we...@googlegroups.com
Ok FF9 is the most painful one so far....I suspect it'll get worst.


Both Linux 64 and 32 should be working.

I am still working on Windows and Mac. Don't install it on those platforms yet.

-Alan

On Thu, Dec 22, 2011 at 12:45 AM, tmy <tmy....@gmail.com> wrote:
Looking forward to the good news, but it is really annoying that the extension is incompatible after firefox upgrades every time, especially today firefox updates much more frequently.
Anyway, thanks so much, Alan! 

--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.

Thomas Broyer

unread,
Dec 22, 2011, 4:37:22 AM12/22/11
to google-we...@googlegroups.com
I can't remember if it had been said in this thread already or not, but the GWT team is working on a replacement for the DevMode that would work without browser plugin (think Dart's frog server, Closure script, and I believe I saw something similar for CoffeeScript, but cannot find it back): https://plus.google.com/s/gwt%20super%20draft%20mode

Alan

unread,
Dec 22, 2011, 2:49:03 AM12/22/11
to google-we...@googlegroups.com
thank u, nice work.
the next Firefox9...

2011/11/9 Alan Leung <acl...@google.com>
Hi all:

I just finished building / testing the FF8 dev mode plugin for Linux 32 bit (http://www.sendspace.com/file/h8wgmn)

More to come tomorrow.

Again, if you are using FF8 already. I'd greatly appreciate if you give that a try and let me know when you see anything weird.

-Alan

--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.
To post to this group, send email to google-we...@googlegroups.com.
To unsubscribe from this group, send email to google-web-tool...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/google-web-toolkit?hl=en.



--
Yours
Alan

Alan Leung

unread,
Dec 22, 2011, 7:28:39 AM12/22/11
to google-we...@googlegroups.com
Alright, FF9 tested on all OS. Let me know if you run into any problems.

http://www.mediafire.com/?831pp1kk5p8kgjd

-Alan

Peter Willert

unread,
Jan 31, 2012, 3:30:35 AM1/31/12
to google-we...@googlegroups.com
9 worked great, but now fx 10 is on the horizon :-/ ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/10.0/

Anyone here who can build the fx10 extension?

Samyem Tuladhar

unread,
Jan 31, 2012, 12:28:32 PM1/31/12
to google-we...@googlegroups.com
Would have been great if the gwt plugin auto-updates when FX upgrades. FX10 is already showing auto updater up on my computer. 

On Tue, Jan 31, 2012 at 3:30 AM, Peter Willert <peterw...@gmail.com> wrote:
9 worked great, but now fx 10 is on the horizon :-/ ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/10.0/

Anyone here who can build the fx10 extension?

--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.

Alan Leung

unread,
Jan 31, 2012, 12:41:45 PM1/31/12
to google-we...@googlegroups.com
As much as I'd like to, that isn't possible. xulrunner 10.0 was just released an hour ago.

Samyem Tuladhar

unread,
Jan 31, 2012, 12:46:12 PM1/31/12
to google-we...@googlegroups.com
I also got selenium plugin and it seems to be able to auto-update after FX upgrades automatically. Is this because selenium team would have access to the xulrunner before hand? 

Thomas Broyer

unread,
Jan 31, 2012, 5:12:19 PM1/31/12
to google-we...@googlegroups.com
Selenium probably doesn't use a binary component, which dev mode have to use. We talked about using js-ctypes which would allow forward compatibility, but that's not possible.
Reply all
Reply to author
Forward
0 new messages